Download

Failing to launch Face AR Sample to iphone x (ERROR: Stage Failed. Missing receipt)

When I try to launch the FaceARSample to an iphone I get the following error:

LogPlayLevel: ********** STAGE COMMAND STARTED ********** LogPlayLevel: Error: ERROR: Stage Failed. Missing receipt ‘/Users/dondoo/Desktop/FaceARSample/Binaries/IOS/FaceARSample.target’. Check that this target has been built. LogPlayLevel: (see /Users/dondoo/Library/Logs/Unreal Engine/LocalBuildLogs/Log.txt for full exception trace) LogPlayLevel: Completed Launch On Stage: Build Task, Time: 10.910269 LogPlayLevel: AutomationTool exiting with ExitCode=103 (Error_MissingExecutable) LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 0.000312 LogPlayLevel: Error: RunUAT ERROR: AutomationTool was unable to run successfully. PackagingResults: Error: Launch failed! Missing UE4Game binary. You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:

How to recreate:

  1. Download Unreal engine 40.20 - 4.23
  2. In launcher create Face AR Sample project
  3. Open Keychain Access, click Keychain Access > Certificate Assistance > Request Certificate from a certificate authority and complete process including downloading certificate
  4. Go to apple developer account, create necessary Certificate and Identifier and link iphone x device and download provision an certificate.
  5. Open project and go to Settings > Platforms > iOS and import the provision and certificate, select checkbox next to the right ones, Enter app name and bundle identifier , set minimum OS version to 11.
  6. Connect iphone x and press launch

I have tried the following:

  1. Deleting Binaries, Intermediate and Saved folders from the project folder
  2. Building first
  3. Packaging
  4. Instead of just pressing launch I opened project launcher and created a custom launch profile and enabled build on that custom profile and launched and got a whole new error(same error when I try to package):

UATHelper: Packaging (iOS): ********** BUILD COMMAND STARTED ********** UATHelper: Packaging (iOS): Running: mono “/Users/Shared/Epic Games/UE_4.23/Engine/Binaries/DotNET/UnrealBuildTool.exe” FaceARSample IOS Development -Project=/Users/dondoo/Desktop/FaceARSample/FaceARSample.uproject /Users/dondoo/Desktop/FaceARSample/FaceARSample.uproject -NoUBTMakefiles -remoteini="/Users/dondoo/Desktop/FaceARSample" -skipdeploy -Manifest= /Users/dondoo/Desktop/FaceARSample/Intermediate/Build/Manifest.xml -NoHotReload -log="/Users/dondoo/Library/Logs/Unreal Engine/LocalBuildLogs/UBT-FaceARSample-IOS-Development.txt" UATHelper: Packaging (iOS): Compiling against OS Version 11.0 [minimum allowed at runtime] UATHelper: Packaging (iOS): ERROR: Unhandled exception: System.FormatException: Input string was not in a correct format. UATHelper: Packaging (iOS): at System.Number.ThrowOverflowOrFormatException (System.Boolean overflow, System.String overflowResourceKey) [0x0001a] in :0 UATHelper: Packaging (iOS): at System.Number.ParseSingle (System.ReadOnlySpan1[T] value, System.Globalization.NumberStyles styles, System.Globalization.NumberFormatInfo info) [0x00071] in <a104f9cbbafd4348bcc580acb0a3f8a8>:0 UATHelper: Packaging (iOS): at System.Single.Parse (System.String s) [0x0001a] in <a104f9cbbafd4348bcc580acb0a3f8a8>:0 UATHelper: Packaging (iOS): at UnrealBuildTool.ReadOnlyIOSTargetRules.get_RuntimeVersion () [0x00010] in <55005cea58344f71ab61265be43fc684>:0 UATHelper: Packaging (iOS): at UnrealBuildTool.IOSPlatform.SetUpEnvironment (UnrealBuildTool.ReadOnlyTargetRules Target, UnrealBuildTool.CppCompileEnvironment CompileEnvironment, UnrealBuildTool.LinkEnvironment LinkEnvironment) [0x00226] in <55005cea58344f71ab61265be43fc684>:0 UATHelper: Packaging (iOS): at UnrealBuildTool.UEBuildTarget.SetupGlobalEnvironment (UnrealBuildTool.UEToolChain ToolChain, UnrealBuildTool.CppCompileEnvironment GlobalCompileEnvironment, UnrealBuildTool.LinkEnvironment GlobalLinkEnvironment) [0x00bc8] in <55005cea58344f71ab61265be43fc684>:0 UATHelper: Packaging (iOS): at UnrealBuildTool.UEBuildTarget.Build (UnrealBuildTool.BuildConfiguration BuildConfiguration, UnrealBuildTool.ISourceFileWorkingSet WorkingSet, System.Boolean bIsAssemblingBuild, Tools.DotNETCommon.FileReference SingleFileToCompile) [0x00061] in <55005cea58344f71ab61265be43fc684>:0 UATHelper: Packaging (iOS): at UnrealBuildTool.BuildMode.CreateMakefile (UnrealBuildTool.BuildConfiguration BuildConfiguration, UnrealBuildTool.TargetDescriptor TargetDescriptor, UnrealBuildTool.ISourceFileWorkingSet WorkingSet) [0x00141] in <55005cea58344f71ab61265be43fc684>:0 UATHelper: Packaging (iOS): at UnrealBuildTool.BuildMode.Build (System.Collections.Generic.List1[T] TargetDescriptors, UnrealBuildTool.BuildConfiguration BuildConfiguration, UnrealBuildTool.ISourceFileWorkingSet WorkingSet, UnrealBuildTool.BuildOptions Options, Tools.DotNETCommon.FileReference WriteOutdatedActionsFile) [0x0001a] in <55005cea58344 f71ab61265be43fc684>:0 UATHelper: Packaging (iOS): at UnrealBuildTool.BuildMode.Execute (Tools.DotNETCommon.CommandLineArguments Arguments) [0x002cc] in <55005cea58344f71ab61265be43fc684>:0 UATHelper: Packaging (iOS): at UnrealBuildTool.UnrealBuildTool.Main (System.String] ArgumentsArray) [0x00291] in <55005cea58344f71ab61265be43fc684>:0 PackagingResults: Error: Unhandled exception: System.FormatException: Input string was not in a correct format. UATHelper: Packaging (iOS): Took 27,614562s to run mono, ExitCode=5 UATHelper: Packaging (iOS): UnrealBuildTool failed. See log for more details. (/Users/dondoo/Library/Logs/Unreal Engine/LocalBuildLogs/UBT-FaceARSample-IOS-Development.txt) UATHelper: Packaging (iOS): AutomationTool exiting with ExitCode=5 (5) UATHelper: Packaging (iOS): RunUAT ERROR: AutomationTool was unable to run successfully. PackagingResults: Error: AutomationTool was unable to run successfully. PackagingResults: Error: Unknown Error

Hi Vadim,
I will ask you in russian…

я пытаюсь запаковать приложение в UE4.23 из-под Windows 10 с подключенным через SSH Macbook Pro для компиляции некоторых элементов и у меня такая же проблема. Input string was not in a correct format.

Что именно я должен добавить в UEBuildIOS.cs ?