Failing Packaging build for Windows

When trying to package an internal release of our experiment in shipping mode (Win32), I got the following error:

Missing UE4Game binary.
You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:
UE4Game <Platform> <Configuration>

The only change we made was to change the Minimum OS Version compatibility to XP (by mistake).
This setting adds the following flag in the ini file, with a value corresponding to it (Vista or XP).


The point is, even reverting it back to Vista, the build fails with a strange error in the log, such as:

Missing UE4Game-Win32-Shipping_xp.exe...

We finally managed to rebuild the project removing manually the MinimumOSVersion line from the DefaultEngine.ini

Our project is a blueprint only one.
The other solution would be to rebuild UE4 from sources, I suppose.

Hey lucabelluccini-

Where in the ini file did you add the “MinimumOSVersion” line? Do you have the same error if you package for Win64 instead of 32? Are there any other changes that need to be made to a new project to reproduce the error?


I did not add any line in the ini file.
I noticed the line in the ini file is not present when creating a new project.

Once you change the Minimum OS Support in the Project settings, the line is added (and its value will change between Vista and XP) and (at least for us) you will no more be able to finalize the packaging.

I was able to package successfully after changing the Minimum OSVersion setting in Project Settings->Platforms->Windows. The line was added in the DefaultEngine.ini file under the heading “[/Script/WindowsTargetPlatform.WindowsTargetSettings]” and was set as “MinimumOSVersion=MSOS_XP” Does this match what was set in your DefaultEngine.ini file? Also does the crash occur in a new project if you only change the MinimumOSVersion setting and then package?

If MinimumOSVersion is present, I am unable to build.

It is not crashing, just stopping the build because it is searching for the binary file “UE4Game-Win32-Shipping_xp.exe” (even if I set back to Vista in the menu).

The project was created long time ago (several months) using UE 4.7

Just so I know I followed the same process, you are referring to File->Package Project with the build configuration set to shipping and then selecting Windows->Windows (32-bit) correct? Do you have the same package error in a new project after changing the minimum OS in the editor?

I have to try out. I am doing support to a friend who is using UE4 and I have to plan a remote session to check it out.

Hey lucabelluccini-

After further testing I received the same error after converting a project from 4.9 to 4.10. I have entered a bug report (UE-23870) to investigate this further. For now you can try adding a new class to the project through the editor. Adding the class forces the project to perform a hot reload which allowed my project to proceed without the error.


I got this issue on 4.18 (not the GitHub version) in my project and a blank new project too. This was happen when I try launch my project on my Moto G 4 Play with Android 6.0

PackagingResults: Error: Launch failed! Missing UE4Game binary.
You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline: