Failed to run init commands on remote server. Output = Permission denied

For the past 10 hours I have been trying to resolve this godforsaken error.

So we used to remote build our project from our win7 machine to a mac mini with no issues at all using the Generate SSH Key.

Yesterday we’ve upgraded the system to win 10 and re-installed everything needed and than tried to set up the remote build but with no success.

The SSH generation output shows an errorless connection between the machines and I am also able to view both of the computers on our local network but when trying to build I receive this piece of error:

Failed to run init commands on remote server macDev. Output = Permission denied (publickey,password,keyboard-interactive).

We have tried everything, disabling Windows Defender, disabling the firewall, setting up the RemoteToolChainPublic.key permissions to be USER with Full Control,
Installed Cygwin and messed up with the files through there, Installed DeltaCopy, Removed DeltaCopy But nothing would hold.

Here’s is the Log result from one of the failed builds.
There mus be a way to remote build with win 10.