Download

Failed to route PostInitProperties

Hello everyone!

After moving to UE 4.25 my project stopped working on Android and I’m still trying to understand what’s going on, I’ll appreciate any help with that. Phone is OnePlus 3T, OxygenOS 9.0.6 based on Android 9. Default third-person template works (tested with ETC2 and ASTC). However in my BP-only project, after launch, critical error shows up in the logs and always originates in my WidgetBlueprints inheriting from one WB parent. It says it “Failed to route PostInitProperties”. Full error log below: https://answers.unrealengine.com/questions/960381/failed-to-route-postinitproperties.html

Maybe it’s something obvious I don’t see or don’t know how to properly debug it. Thank you in advance for any help!

I tried to make it work on 4.25.1 and problem still persists. The strange thing is, I tried to detach my children UserWidgets from parent UserWidget (there are only a few variables and functions inside, as I know widgets hierarchy cannot be inherited) and at some point, when there was still some children connected to parent left, the project launched without problem… once, maybe twice. So it was still semi-random, but at least worked sometimes. It honestly doesn’t look like something I have much control over and considering it’s a BP based project, I don’t know what more I can do myself. I still have a real problem with narrowing the issue enough to send it as a replicable bug. I mean, it is replicable 100% in my project, but it would be best to replicate this in an empty template.

I would appreciate the help from engine developers, if possible.

Just to let know to anyone who it may concern, it seems the problem has been resolved. Fix is already available in a custom engine build, so at some point will end up in the launcher version too. Big thanks to everyone who supported Epic in dealing with this issue! Cheers!
https://answers.unrealengine.com/questions/960381/failed-to-route-postinitproperties.html