Failed to read environment variables from XML file after update to 4.8.3

Hi there, I updated my project from 4.7 to 8.3, and after I corrected some things in C++ which has changed, I can get the editor opening the project again, but when I click on compile in the editor I get this error:

Info ERROR: Failed to read environment variables from XML file: C:\Users\AppData\Local\Temp\tmp1BC2.tmp

the .tmp file seems to be empty

and there is also a .tmp.bat file containing this:

call "C:\PROGRA~2\MICROS~2.0\Common7\Tools\../../VC/bin/X86_AM~1/VCVARS~1.BAT"
"D:\EPICGA~1\4.8\Engine\Binaries\DotNET\ENVVAR~1.EXE" "C:\Users\\AppData\Local\Temp\tmp1BC2.tmp"

Update: when I run the .bat file manually, the .tmp file is filled with valid XML with environment variables. I checked with an XML validator.

Any idea what the problem is?
Or is there any information in general about the whole building process, so I could try to debug this myself?

The only way I can get it to work is to download the source of UE4, then run the star the editor in debug mode and open my project from there. If I run the UE4 from source without the debugger (using the .exe) I get the same problem with the environment variables. That’s annoying cause that means I can’t debug the error in the build process. Any ideas how to debug this?

Also when I start the exact same command (D:/UnrealEngine/Engine/Binaries/DotNET/UnrealBuildTool.exe ProjectName -ModuleWithSuffix ProjectName 8158 Win64 Development -editorrecompile -canskiplink “D:/ProjectName/trunk 4.8 - 2/ProjectName.uproject”
from a .bat file, it builds fine… but from the editor it gives this XML environment variables error… any help please?

Hi BramV,

Sorry for the delayed response. Am I correct in understanding that you are seeing this issue occur when trying to open the project that you upgraded from 4.7 to 4.8? Is this only happening in one project (if you make a new project in 4.7 and upgrade it to 4.8 does it have the same results)? Are you able to run the Editor itself and create new projects without any problems?

Hi BramV,

We have not heard back from you for a few days. Do you still need help with this issue? I will be marking this post as resolved for tracking purposes, but please feel free to add a comment and re-open the post if you need any additional help.