Failed to produce item/Exited with code -1

Hi guys,

Just trying to set up Unreal + VS2013 on my work and it’s having none of it, I’m getting the following errors whenever I try and build the project:

Error 1 error : Failed to produce item: C:\Users\will.masek\Dropbox\Unreal Projects\QuickStart\Binaries\Win64\UE4Editor-QuickStart.dll C:\Users\will.masek\Dropbox\Unreal Projects\QuickStart\Intermediate\ProjectFiles\ERROR QuickStart

Error 2 error MSB3073: The command ““C:\Program Files\Epic Games\4.8\Engine\Build\BatchFiles\Build.bat” QuickStartEditor Win64 Development “C:\Users\will.masek\Dropbox\Unreal Projects\QuickStart\QuickStart.uproject” -rocket” exited with code -1. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets 38 5 QuickStart

This is a Windows 8 machine, I have installed VS2013 Express for Windows Desktop.

I have checked the Environment Variable as suggested in other threads and that looks to be fine… I’ve tried to uninstall/reinstall VS2013 but still no joy…

… Is there any hard and fast fix for this?

One note, I do have TWO other versions of Visual Studio installed (2010 and 2012).


Hey -

You may want to check that you have DirectX 11 installed. The folder path for your project may also be too long, I would try creating the folder in a more centralized folder (C:/Unreal Projects/) and then compile again. Let me know if you’re still having problems as well as the answers to the following questions if you are. Are you getting this error when trying to compile an existing project or when compiling a new project for the first time? Do you get the same error when compiling other projects or is it isolated to a single project?


Hi , thanks for your response.

According to DxDiag I do have DX11 installed.

I don’t have any pre-existing projects but I get this error with every new project I create (I’m trying to do the QuickStart programming tutorial).

I just tried creating a project in C:\Unreal Test and I get the same error so it doesn’t seem to be related to length of filepath.

Additionally when I create a New Project I get the following error:

Running C:/Program Files/Epic Games/4.8/Engine/Binaries/DotNET/UnrealBuildTool.exe Test Development Win64 -project=“C:/Unreal Test/Test/Test.uproject” -rocket -editorrecompile -progress -noubtmakefiles
Parsing headers for TestEditor
Reflection code generated for TestEditor

“ERROR: UBT ERROR: Failed to produce item: C:\Unreal Test\Test\Binaries\Win64\UE4Editor-Test.dll
XGE execution time: 49.04 seconds”

N.B. I am going New Project → Basic Code → Create

Are you using the Launcher version of the editor or was the editor built from github source code? When compiling the project are the solution configuration and solution platform in VS set to Development Editor and Win64 respectively? Can you post the build result from the Output tab rather than the Error List tab, this may provide additional information to help identify the problem.

I’m using the Launcher version of the editor.

I can confirm the Platform and Configuration are set accordingly.

Here’s the build output…

1>------ Build started: Project: QuickStart, Configuration: Development_Editor x64 ------
2>------ Skipped Build: Project: UE4, Configuration: BuiltWithUnrealBuildTool Win32 ------
2>Project not selected to build for this solution configuration
1> Compiling game modules for hot reload
1>ERROR : UBT error : Failed to produce item: C:\Users\will.masek\Dropbox\Unreal Projects\QuickStart\Binaries\Win64\UE4Editor-QuickStart-1383.dll
1> XGE execution time: 3.44 seconds
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command ““C:\Program Files\Epic Games\4.8\Engine\Build\BatchFiles\Build.bat” QuickStartEditor Win64 Development “C:\Users\will.masek\Dropbox\Unreal Projects\QuickStart\QuickStart.uproject” -rocket” exited with code -1.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 1 skipped ==========

I’ve installed the same setup on another machine and it seems to be working fine…

Main differences between the two are:

  • The working machine is Windows 7, the broken one is Windows 8.
  • The broken machine as I said before also has VS2010 and VS2012 installed (which I need for work so can’t get rid of).

OK this is only happening in the Win64 Platform, Win32 compiles fine…

Hey -

After compiling for Win32 were you able to open and use the project? I just want to confirm that you were able to solve the problem of the project not compiling.

No it doesn’t actually run, I get a windows popup error:

Unable to start program …\QuickStar.Exe

The system cannot find the file specified.

Are you able to create blueprint based projects? If so can you also try adding code to the blueprint project by going to File → Add Code to project. You may want to also verify the engine version you’re using by clicking on the drop down arrow next to Launch on the Library tab of the Launcher then select Verify. If you’re still having problems then try uninstalling/reinstalling the engine version.

Yeah I can create blueprint projects. There is no “Add Code” option under File however?

When I try File → Generate Visual Studio Project I get the following error:

An error occurred while trying to generate project files.

Running C:/Program Files/Epic Games/4.8/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“C:/Users/will.masek/Dropbox/Unreal Projects/TestBPProject/TestBPProject.uproject” -game -rocket -progress
Discovering modules, targets and source code for game…
UnrealBuildTool Exception: ERROR: Directory ‘C:\Users\will.masek\Dropbox\Unreal Projects\TestBPProject’ is missing ‘Source’ folder.

But yeah Blueprint projects seem to work OK… this starting to sound like an issue with Visual Studio more than anything. I’ll try a fresh reinstall of everything and see what happens.

Hey -

Have you tried reinstalling VS to see if that helps at all? If you’re still having problems creating a code project then it is possible that the other versions of VS are causing an issue. I would try removing them temporarily to see if you can create a project. If that doesn’t help please list the steps you’re taking when creating the project and where you run into the error.


Thanks , I’ll keep trying and let you know the outcome.

Thanks , I’ll keep trying and let you know.

Hey -

Have you had any luck in your test to build the project? Did reinstalling Visual Studio or removing the other versions of VS help? You may also want to try verifying the engine version through the launcher or using a different engine version to create the project.

I installed Unreal Engine today and ran into this message.

This may not be your issue, but my disk drive went full after making several projects on it since I was using the default path on my c:\ drive and I use a smaller SSD drive for the O/S. I switched to another drive with plenty of space for my project and it builds now! Good luck!