Failed to play IOS game on other devices

I am creating a game for IOS, it builds successfully and it launches on my iPhone, but when i tried to launch it on my Father’s iPhone, it fails.
I created the IPA file and synced it through iTunes, but on his iPhone it doesn’t finish the “Installing” Phase.
His UDID has been also added to my developer account. We are both using an iPhone 5S on IOS 8.
I am using a PC, not a mac .
Do i need to do something else except adding his iPhone to my Developer Account?
Thank you.

Have you downloaded the updated provisional profile after you added the device?

No, i haven’t.
I’ll try it out and will let you know. Thank you.

I am still having this problem. I have re- exported the provisioning profile with the updated UDID’s but it still doesn’t work.
Any tips?

Hi Ash1029,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes. If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, could you please submit a new report for it.