Failed to open map file

Still this same error :confused:

When i’m created a new project 4.10.2 it’s all ok. This bug is fixed, but now is my first problem. How i can fix my older project? I need to fix because i working many hours on it.

Unfortunately the project sounds like it may be corrupted. Try moving the contents from your project into a new project and see if you can continue to work on the same assets, if not, the error you are experiencing may be asset specific.

Ok. How i can save a possition of my assets? If from the beginning I’ll have everything set i lose a lot of time.

The way I would do this is create a new project, then open the windows explorer and navigate to your original project. Open the contents folder and copy all of the folders within to the new projects content folder filepath. Once you open the new project immediately fix up redirectors on the Content Browser and see if this allows you to continue working.

Hi V4nder,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

I did as you wrote but there is one problem . When I turn on the project i must open level and load my map. How can i set this map as default?

If you go into Project Settings>Maps and Modes you should be able to set the default map there.

Ouch, “Map is saved in newer version” … New project don’t help me :confused: i don’t have idea what i can do now.

Unfortunately it may be a corrupted map file. Try creating a new map and follow the same steps, do you have any errors occur if you use a new, blank map?

No, when i create new project is all ok. Only my previous project is broken :confused: I heard something about program which uses C++ for change version.

Do you mean the github source branch? We do have a source build if you would like to give it a try. You can find it here:

If this is not what you are looking for, can you clarify what you mean?

That’s it. What do you think about this? This can help me?

It is worth a shot. I cannot guarantee that it will be a solution to the errors you are seeing, but it is worth taking a chance to find out if it will resolve your error.

Unfortunately, there is not much else that can be tried. If the map file is corrupt the best you can do is use a backup copy if you had one or scrap the map and start over. There aren’t any other options that will feasibly help, even using the source build is a longshot at best and more than likely will not resolve the error.

I will try this. but please next ideas from your side . I will be grateful.

Ok. Anyway all working good, but only this error is irritating.

I’m happy to hear the new project is working well. I am marking this as answered for tracking purposes. If another map begins to show the same errors, please comment back and I’ll be happy to take another look.

So I’ve recently had this same error happen in our project, and even if I go to a backup and pull it and try and use it, or re-create the map, the error has come up twice now, on two different versions of the same map.

I am using Save-As, saving an existing map as a new map, can save, and edit the map blueprint, but at some point when I save, exit unreal, and come back, I get the “map was saved using a newer version of Unreal” error.

Your map is corrupted. You can not do anything about it. You have two ways :

  1. You can create new project and copy content.

  2. Open project, click ok on the error. Then open map backup. Unfortunately, every time you will have to do so.