Download

Failed to open map file. This is most likely because the map was saved with a newer!!

Failed to open map file. This is most likely because the map was saved with a newer version of the engine.
ill repeat that for you guys just encase you missed it the first time !!!
Failed to open map file. This is most likely because the map was saved with a newer version of the engine.

There is a project i am working on ,i have been working on it for 4 mouths now ,4 hours everyday so now that unreal engine 4 has come out i decided to redo it all.about 8 hours a day (i even hired someone to help). now as we all know that cost money and well time.

Now when i try open the project it get the lovely message (Failed to open map file. This is most likely because the map was saved with a newer version of the engine.) ok and well this message was designed to make people crawl on the floor,suck there thumb and cry ok.

More information on the problem.

*It only happens for that project,all the others work just fine.
for example. My_Project1 (working fine) , My_Project2 (working fine) Unforgiving Stars (NOT WORKING) ,My_Project3 (working fine)

*This error happend after i just restarted my PC
(turn off and back on)

*I have been working on this project as soon as Unreal Engine 4 came out

*anything else please just message and ask

Thank you in advance :smiley: :confused:

HAHA i found a fix if anyone is reading this in the Future

STEPS BELOW

1.close ue4

2.locate mydocument/unreal projects/(‘your project name’) for exaple my_project65/Saved/Backups

3.they sould be named by date .(just find the one with the most recent date) now wait

4.start ur4

5.open your project and click ok to the sad message :frowning:

6.click file

7.open level

8.locate the backup file i told you to remmember and open it

9.and wala that works :smiley:

10.if it doesnt then im sorry but i cant think of anything else but just message me cause i might have thought of a fix by the time you are reading this :smiley:

ok found out another way

1.just copy all your scene content

2.go to your project location and delete the ‘Maps’ file

3.start UDK up again and paste (control+v) and wala

but every time you start up you UE4 you need to open level

Dude you saved me, i just had this happen to me and couldn’t figure out why but luckily there was a backup!

Always use version control. I use Git hosted at bitbucket. SVN and the SVN integration in UE4 sucks. Git is command-line and fast.

Thanks man u save me

Thanks Man it works for me!!

Care to show how to set it up at all? I’ve been trying desperately to get ANY kind of version control functioning in any way.

Literally can’t get anything to work. It’s like bashing my head against a brick wall. Everyone has a different solution that either isn’t viable or simply doesn’t work.

And if you don’t use version systems for your assets, make regular backups of them, like daily plus whenever you do dangerous things, and **never **update your project to a new engine version with your sole copy of the project.

I have my code in git and have a script to create 7zip files of my assets. I tried to setup Perforce for my assets but Im not intelligent enough to get that done. :wink:

Yeah, replacing map with saved/bakups file work for us.

:slight_smile:

I’ve gotten this stupid error message one too many times.

Here’s usually what happens:

  1. See that a new version of the engine is out (4.7.0) . Download the source code and build it!
  2. Get the latest build from the Master branch on Github (which is more recent than the release version). The version.h is pushed to 4.8.0
  3. Use this version without updating anything for several weeks.
  4. Another version of the engine comes out (4.7.4) and we download it. It has more features!
  5. I download and compile 4.7.4 engine source

Uh oh… the older unsynchronized version of 4.8.0 is behind version 4.7.4, but the engine thinks that all of our assets were built using 4.8.0. It pukes when it tries to load “newer” assets.

I go into the UE4 version.h file (\Engine\Source\Runtime\Launch\Resources\Version.h) within the engine source and change the version back to 4.8.0.

Does this work? No, of course not. That would be too easy.

Every asset file you create has the “Object” version encoded into the uasset binary. When the engine goes to load your uassets, it looks at this internal package value and compares it against the current engine package value. If there is a mismatch, you may be lucky enough to get an error. Or, it just doesn’t show up in your content browser and you have no idea why.

So, you have to go into the ObjectVersion.h (\Engine\Source\Runtime\Core\Public\UObject\ObjectVersion.h) file and make sure that the enumeration values are up to date. Epic keeps an internal enum list of changelogs which it uses to figure out the package version for your assets. So, if your package version was 847 but the engine package value is 830, the engine will think that the package is newer and it refuses to load it. I just copy/paste the newest enum values (or just add some placeholders) to bump the engine value so that its higher than the package value. This lets your assets show up properly. However, of course, you need to be really careful about proper version control. This is a dirty hack and is prone to cause breakages if you don’t know what you’re doing.

Wouldn’t it be nice if UE4 just tried its best to load as many parts of a package or level and just throw warnings or errors for the bits which it doesn’t recognize? If you resave, you get your data for the current engine package version…

What is the click file and such. can you describe exactly what you are gonna click on

I’m really sorry if I duplicate posts,but I can’t open the maps.UDK can’t open the maps as UE4.

UDK and UE4 files are not compatible

so is there any desert map to udk?Anyways I can’t play kismet jackrabbit as udk 2015 update

i have also this interrupting problem which is still annoying me

i really shouldn’t quadriple posts again to not gain the banishment.

If you have any UDK questions, post on the UDK forums: https://forums.epicgames.com/forums/366-UDK

Hey Andrew I have the same problem, but when you say the scene content is all folder of the startcontent? or all folder of the project? please let me know the location Andrew, Really thanks

hmm whwn i click file-open level then a window apears in which i cant locate to the saved folder i can only locate in the Content folder… please help

Open it with What? I have UMAP and UASSET files in this folder and I have no idea what to do with them to restore my level.

I FOUND A SOLUTION ON THIS PROBLEM!!!

  1. Right click the project
  2. Select show in folder
  3. Locate Saved folder and go to the back-up
  4. Copy the latest back-up file then paste in project map folder
  5. Delete the original level map
  6. Rename the copied back-up file the same as the original
  7. Now open your project
  8. And done ur project is fix. :slight_smile:

What software are you using? Maybe try opening the project like this: https://www.mindjet.com/mmap-file/ in case it does’t work, I would say it is a bug somewhere in the file itself since the others open just fine.