Download

"Failed to open descriptor file" error with Android target

Hi! I have a mobile game in development. It works fine with Android target SDK 28, but due to Google restrictions, I need to update the target SDK version to 29.

I can successfully build a game, but after deploy when I open the game I see an error message “Failed to open descriptor file …/…/…/GameName/GameName.uproject”.

I tried to disable plugins or package project first and then launch it, but no luck, the same error.

My building params: Building Java with SDK API level ‘android-29’ LogPlayLevel: Building with Build Tools version ‘29.0.3’ NDK toolchain: r21b, NDK version: 21, GccVersion: 4.9, ClangVersion: 9.0.8 LogPlayLevel: Compiling Native 32-bit code with NDK API ‘android-21’ LogPlayLevel: Compiling Native 64-bit code with NDK API ‘android-21’

What I’m doing wrong? Am I missing something?

UE 4.25.3

Привет) У тебя получилось исправить это? Я тоже с этим столкнулся :frowning:

Check the answer here: https://answers.unrealengine.com/que…4736/view.html