Download

"Failed to load map!" .. appears to be an asset.

Hey all,

I’ve recently been assigned to a project and downloaded the source from Github. However, when I try to open the project, the editor produces a message claiming the .umap file failed to load as it appears to be an asset. It also doesn’t appear in the content browser, or the file browser (opened via ‘File → load level…’ etc).
I’m using the correct engine version the project was originally developed in (4.8), and the same VS 2013 version.

Anyone come across this issue before? And if you did, did you find any solutions?

Thanks for anything you can tell me!

Bump.

Normally I’d not bump so soon, but I really need to find a way to get this map loaded in.
Anyone who could even offer suggestions would be greatly appreciated.

Ive been getting these issues tons lately when changing folder names. Not only that, but Id constantly lose all the work in the map because it would no longer load.

Problem solved. Some of the data for the .umap was being lost due to interference of Git LFS when cloning. All good now :slight_smile:

@Shirk How do you change them, inside UE4?
:slight_smile:

Yeah I change them inside the editor, but unless you fix the broken referencing before you save, you have the potential to mess everything up.

I’m having the same problem, what did you do to fix it ?

You’ll just need to get a version of the file which hasn’t been passed through Git LFS

Thanks, this solved the issue for me when opening a project on Mac which had been created on PC (transferred via GitHub with Git LFS enabled). Is this a general issue with Git LFS and .umap files? Is there another solution to the problem besides not tracking .umap files with Git LFS?

Similar issue here, Editor says:
“Failed to load map!
D:/Unreal Projects/FPSZombies/Content/ThirdPersonBP/Maps/ThirdPersonExampleMap.umap appears to be an asset file.”

Found the fix as well, delete any UMAP or BuildData files that may be inside of your project. Once these are gone you will be able to select your default map again. (Dont delete your current map/build data)