Failed to launch editor

I am trying to open a project in UE4.20 by double-clicking the project, but I get a pop-up error that says “Failed to launch editor” (see picture attached). I am able to open the project if I launch UE4.20 through the launcher (by selecting the yellow button “Launch Unreal Engine 4.20.3”) and then open the project within there. I am also able to launch the editor without problems if I run the exe directly from the 4.20 engine program folder.

I have tried countless things to fix or isolate the issue: deleting the intermediate folder, reinstalling UE4.20, “Verifying” the engine, restarting my computer, etc. I also found that this issue is not project-dependent; I made a second dummy project and again was not able to open it from launching the engine from the project (by double-clicking).

Nothing seems to work when trying to launch UE4.20 editor from the project rather than from the launcher or the exe file, and I am not really sure what is wrong. I am also not able to move to a newer version ( UE4.21 or UE4.22) because the plugins I am using only work with UE4.20.

Please help!