"Failed to Import For Object Property"

We are getting Error00.png upon editor launch when Error01.png code in executed in Error02.png (Macro: Get Units Item_Unit Size_Y).

It should be executing in run time. When removed from flow, reopening the editor does not give an error.
Tried adding IsValid check for the object, it didn’t make a difference either.

Hello onuryurdupak,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any other blueprints that may be involved with this issue?
  4. Could you elaborate on what it is exactly you are trying to accomplish?

I am afraid I can’t assist much in ways of reproducing the issue due to being short on time. The point of creating and removing a widget was to read a variable stored in it and It worked as it was intended (during runtime). But the error message created some confusion. We made a workaround for it and got rid of the error message.

I am happy to hear that you were able to find a solution to the issue that you are having. Would it be possible for you to provide the workaround that was used to solve your issue?

Well, not really a workaround but an less preferrable alternative really. I put the variable into DefaultHUD and reversed the workflow. The widget Y size is set to that constant value (read from a float variable) right after Event Construct.

Hello onuryurdupak,

Thank you for providing the solution that works for you. I will be marking your last comment as answer. If this issue returns please feel free to reopen this issue with information regarding a reproducible test case and I will be more than happy to assist you further.

Make it a great day