Failed to import animations Blender -> UE

Since 4.8 it is not possible to import animation fbx files from Blender. It worked fine in 4.7.6.

Please see also this thread with additional information: 4.8 can no longer import just the FBX Animation Skeleton ONLY, imports fail everytime. - Character & Animation - Epic Developer Community Forums

I tried fbx version 6.1 and 7.4, but with both no luck.

Hi ,

Have you tried the solutions provided at the bottom of the forum thread? Additionally, what version of Blender are you currently using?

I have the same issue with FBXs from Mixamo. I cannot import skeleton only fbx files.

Someone on the forums mentioned that you can use 4.7.6 as a work-around to import your animations, then just migrate them … gonna try that now.

Can you walk me through what steps you are taking to reproduce this on your end? Here is what I did in Blender 2.75 rc:

  1. Create a box with 1 bone
  2. Export box and bone fbx
  3. Import to editor as skeletal
  4. Create an animation in blender (I used a simple rotation animation to test)
  5. Export just the baked animation from blender
  6. Import the baked animation, target the imported skeletal mesh from before

At this point, I did not get any warnings about my skeletal mesh or any import errors related to this. Are you doing something differently than I did?

Hi ,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

Hi ,

sorry for not answering your questions for a long time. I got it working with Blender 2.74 and the new binary fbx exporter. It just needed some other export options and the solution in the forum thread did help.
Thank you for your help and time.

Hi ,

I’m happy to hear you were able to get this working. I’m going to mark this as answered for tracking purposes. If the error occurs again, please comment here and I’ll be happy to take another look.