Failed to find shader map?

I made fairly simple project and built it. No errors, no warning, but when I try to run the app nothing happens.

Here’s the last few lines from the Log file:

[2014.04.02-02.49.49:595][ 0]LogShaders: Verifying Global Shaders for PCD3D_SM5

[2014.04.02-02.49.49:656][ 0]LogWindows:Error: appError called: Failed to find shader map for default material WorldGridMaterial! Please make sure cooking was successful.

[2014.04.02-02.49.49:656][ 0]LogWindows:Error: Windows GetLastError: The handle is invalid. (0)

[2014.04.02-02.49.50:001][ 0]LogWindows: === Critical error: ===

Any ideas?

bump…

link textlink text

Made Windows build and now just trying to run the application :wink:

Hi phoboz,

Could you attach the full log file and the dxdiag to this please so we can better assist you? Thank you and have a great day!

Hi Phoboz,

Are you trying to package this for a phone? What steps are you taking specifically to get this error? Thank you.

I did that 3 or 4 times now, the logs I attached were produced just after clean build.

EDIT: Sorry, didn’t catch that you said Desktop :wink:

EDIT2: I’m afraid it still didn’t work :frowning: Log file

Try to repackage the windows .exe. Follow these steps to see if it works properly:

  1. Open your project
  2. Go to file>Package>Windows
  3. Select desktop for destination, click ok.
  4. Go to your project folder in the new folder on the desktop
  5. Go to binaries>win64>yourprojectname.exe
  6. Double click and let it run

If this does not work please let me know and we can continue troubleshooting. Thank you!

Does it only happen with this project or are all projects that you build having similar issues? Try to build one of the sample projects or a new project and see if that goes through ok. Thank you.

Just tested my other project and it works perfectly fine.

Should I just move all the code and assets to a new project or do you want to keep digging?

If it was reproducible, then we would be able to file a complete report about it. Since this only occurred the once, it’s probably best to move to a new project for now if you want to continue working immediately. If it occurs again, then we can get reproduction steps so that our developers can reproduce and fix the problem.

Thank you for your report.

Hi Phoboz,

We have not heard from you in quite some time. I am marking this as accepted for tracking purposes. If you are still seeing this occur please let us know so we can further assist you. Thank you.

Hello everybody! I am bringing back this thread since i am experiencing the same issue phoboz was getting. Everything runs ok while on the editor, no errors when building and no errors when packing the game. It is just a simple architectural interior level…

I´ve attached a screen capture showing the error. I think we´ve tried almost everything, we´ve also merged all meshes, textures and materials into a new blank project with no success.

Hope someone could help us solve this.

Thanks!

Nico.-

If you still have this problem, here is a workaround that worked for me.