Failed to find mounted volume for /storage/sdcard1/Android/obb/

Hello :slight_smile:

My game becomes larger and larger, so this finally made apk large enough for Google Play to start demanding a separate obb file for it. When the game was little enough and I used single apk - everything worked fine. But when I started using separate obb, game just stopped working. It’s 100% crashing just after start with the following error: “Failed to find mounted volume for /storage/sdcard1/Android/obb/…”. I’m sure that I’ve assembled the build and installed it on my testing device correctly. Game requires only one permission, as intended: WRITE_EXTERNAL_STORAGE.

Any advice on how can I fix the crash?

MrSeival,

In order to better assist you, I’m going to need for you to provide me the logs from your mobile device.

  • Attach your phone to the computer
  • Go here: C:\NVPACK\android-sdk-windows\tools
  • Open up Monitor.bat
  • Launch the program and save the logs

If you cannot get Monitor.bat to open, please go to:

  • C:\NVPACK\android-sdk-windows\tools\lib\monitor-x86
  • Open up Monitor.exe
  • Follow the instructions above

Make sure that you highlight all of the logs, because they do not save unless they’re highlighted.

Thank you!

Thanks for the reply :slight_smile:

I did as you suggested. Please, see attachment (com.RedSpotSylphina.GlasswingedAscensionDemo.txt).link text

Please clean your device and the SD card, restart the device and try again. Thanks!

I tried to install the game via .bat file again before doing as you suggested, and noticed an error. There was a tip after the error - to make sure device has SD card. This device doesn’t have it. Is there any way to configure the .bat file so it will ignore absent SD card and install the game into internal storage?

Do you have enough space available on your device? Have you cleaned it out recently?

There was little space available on the device indeed, but I think that was enough for the game. Later, I freed a lot of space on it (so now it has about 5GB available), and restarted it (didn’t restore it to defaults though, as I need this device not only for testing). Unfortunately, this didn’t help to solve the problem.

Do you have updated logs that you can provide? Have you tested this out on a different device?

Yes, I tested it on another device, and everything worked fine on it. And this is what I actually afraid of. If I have such a strange problem on one of my devices, then theoretically any user may have the same problem after installing the game from Google Play. I cannot just suggest such users to reset their devices in order to launch the game.

In this case publishing the updated game on Google Play would be risky. But, it’s only a free demo version, and I can try to publish it to see users’ reaction, and quickly unpublish, if it will be negative. I’m not sure.

I’ll let you know if I’ll have new info regarding the issue.

Thank you. Update us as much as you’re able to so we can try and assess the problem.

do you solve it? shuo ni ma zhe me jiu.

Unfortunately, I didn’t. The only way to solve the problem is making your game small enough to avoid using obb files.

that’s terrible

in some device if the storage don’t have the write permssion then crash occurs.