Failed to find character movement components

I made a hud using UMG with the mixamo master character blueprint. I have variables hook up like ammo, health, and so on. Everything worked untill I rebooted UE4. Now it failed to find character movement component, capsule component and arrow component. I click on the components in both master and separate character blueprints, but no attributes are there. It won’t let me delete them to add new ones, and if I re import the characters, the components are still not working. No matter what I try its jacked. The error says contact framework team about a bug or something like that. Any thoughts? Need more info?


What version of the editor are you currently using? Additionally, have you been able to reproduce this in a blank project with no additional content?

Hello: I’m using version 4.4.3. I have not try blank project yet. My character blueprint is a little robust, so doing it over again isn’t gonna be fast, I will try. For some reason now when i migrate a mixamo character, it doesn’t migrate all assets. The new master character blueprint that migrates works, as far as movement component, but skeleton doesn’t work, and mesh isn’t there along with other assets. I still have the master that i was working on in a different folder. I’m using all blueprints for everything, I mostly got from the documentation. The following is what I’m using, Networking tutorial , Mixamo character with base blueprint that I added all the networking to, Respawn “not networked” from UE4 doc placed in my game blueprint, and UMG health bar and energy bar UE4 doc, cast to blueprint. I followed all instructions and character blueprint was working, then tried to work with UMG. That’s when things started going wrong. I will try to make same blueprint with UE4 blue dude. lol I’m no pro, only been using UE4 for a few month for fun, but something isn’t right there . Sorry if my explanation isn’t good, just trying to help and get help. Thanks! Need more info?

So I started blank project and added one thing at a time. Added Mixamo character, then HUD"screenshot11". Then added the bomb from the networking tutorial"screensot12’. Also added a bullet mirroring the bomb. Right after finishing, I rebooted the editor and got"screenshot 5. Now i can’t change anything on character. Hope this helps. alt text

alt text


Which object/bp node added was the last added before the error occurred?

It was the networking bomb and bullet bp chain. I had a bomb and bullet spawn working before networked. I rebooted, tested everything , it worked, then added the networking functions for spawning on server “screenshot 12”. I tested it before rebooting, its was working, rebooted the editor then I got the error.

Take out the bullet and return to just the bomb and see if it still causes the same error to occur. I’d like to limit what it could be as much as physically possible.


We have not heard from you in quite some time. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information. Thank you!