Download

Failed to connect to Swarm

Hello UE community,

Just decided to start using UE again, but now i struggle with one weird problem, every time i try to build lightings only or everything, i get “Failed to connect to Swarm” strange the first time i runned UE i had no issues, but then i can’t rebuild it. Tried to check whether my firewall blocks swarm or something that interacts with Epic games, nope no issues at all. Can someone guide me with different ways to solve this ?

Kind Regards.

I am having issues as well. Very recently started. I think the 4.19 update and Windows Defender is blocking me.

I think Microsoft Windows Defender removes the SwarmCoordinator/Agent executable from \UE_4.19\Engine\Binaries\DotNET. I have to restart my computer, disable Windows Defender Real Time Protection, verify the 4.19 installation which puts back the executables in place. Annoying.

Yep that’s definitely strange and annoying. Gonna try that thank you :stuck_out_tongue:

Having the same issue, can’t build lights, getting the error: “Failed to connect to Swarm.” It was working absolutely fine yesterday and I didn’t install any Windows updates.

Confirm, I’m seeing it also. In fact I built lighting just fine 20 minutes before, tried it again and received the “failed to connect to swarm” error.

There is still no luck for me, anyone figured it out? I went to to the path

C:\Program Files\Epic Games\UE_4.19\Engine\Binaries\DotNET and launched HTML5LaunchHelper.exe which apparently activated the server, but that still didn’t help. I could navigate http://localhost:8000 though and i saw the Unreal Web Server

Finally figured it out. For some reason the SwarmAgent.exe wasn’t in the folder:

E:\Program Files\Epic Games\UE_4.19\Engine\Binaries\DotNET

I’ve copied it over from

E:\Program Files\Epic Games\UE_4.18\Engine\Binaries\DotNET and it worked.

I’m going to reinstall UE4.19.

I was able to get around the issue temporarily by disabling windows real time virus detection, and then using the Epic Launcher to “verify” the installation. However real time protection turns itself back on every night. I think windows defender is identifying the swarm .exe’s as a virus and removing them.

Not sure if this is a 4.19 bug or windows bug, but I’m going to search for a more permanent solution tonight. I’m surprised at the lack of attention this is getting, as it seems like it would be a more common issue.

I believe I fully resolved mine, by adding the following Exclusions to windows defender:

Virus & Threat Protection Settings > Add Exclusion > Add Process

EpicGameLauncher

UnrealCEFSubProcess

Add those two exceptions matching the case as well, and you should be able to verify your install without fail, as well as build lighting.

Open the folder SwarmAgent is in -> Right click -> Scan with windows defender -> Select “Allow to run on this device”