Failed to connect to bundle

Hi Guys!

I’m in a desperate need of help please!!!

I am developing a project in Unreal 4.15.2 on Windows which I am trying to deploy to an ipad2 device.

I have generated all necessary provisions and certificates but for some reason once the deployment is complete and
I start the deployed game on my ipad the game crashes and goes back to the ipad screen after the showing splash screen for about 10 seconds.

I even tried to deploy the fresh unreal default First person shooter game which was successful with no issues so I was reading through the log of my project and I found this:

Failed to connect to bundle 'com.test.'

I have been reading through similar posts here and I got my bundle identifier correct, even tried to convert my project to a template as well but still no any luck.

Would anybody happen to know what might cause the problem?

Your help would be much appreciated!

I’m not familiar with iOS development but since answers aren’t easy to come by, I try to help people diagnose their own problem. Usually in the process of proving me wrong they figure out the solution themselves. :slight_smile:

So… one thing I noticed is that it’s failing to connect to “com.test.”. I would think that should either be “com.test” or “com.test.*” or something. Ending with the period seems off to me.

Also, when a log ends abruptly like that it probably means there was a crash and there should be a crash log created by the OS. That may have more info for you.

Thank you for your comment Jin_VE

Actually I did find a solution. The weird thing is Unreal was only able to deploy the project with a “.” at the end of my bundle id. if I do it with a “*” or otherwise it would fail deploying.

The solution for getting my bundle id to connect was to deploy the project again right after an unsuccessful try. Pretty weird… :smiley:

However it still didn’t solve the problem of my game exciting right after showing the splash screen on the ipad.

Try packaging the game and installing it rather than deploying it from the editor. See if it works the first time then. Or have you tried already?

Yes, I have tried it to install through itunes as well…same result. not working…

That’s strange. It’s as if it needs to run and fail once before it gets the bundle it’s looking for. Perhaps it’s because this is a test app? When I try to help people with stuff I don’t know much about, I’m always hoping someone with the right expertise will chime in, but that doesn’t happen often. Try to get some info from logcat/monitor. Maybe there’s something in there – just try to filter out all the stuff that isn’t related to your app. Someone else posted a 30k line log file earlier.

Thank you for the suggestion! I’ll have a look! :slight_smile:

I have the same situation,do you guys solve it ?

Hi Elsa915,

It eventually worked! I had to do 2 things to make it! firstly right after I got the message “Failed to connect to bundle ‘com.test.’” I packaged again. The second time it connected to bundle with no problem. The other thing was to make my project very simple. I had to delete a lot of lighting and only packaged 1 map. Maybe ipad2 can’t handle more (?)

After all this it worked.

Hi there. I ran into this problem and I fixed it by using another iOS device. After attempting to launch the .ipa file through XCode it complained that my device did not have a compatible CPU.