Failed to Connect to Bundle - Unreal 4.18, 4.19 or 4.20

I’ve already tried compiling a clean game in Engine versions 4.18, 4.19 and now at 4.20 and I always find this problem:

LogPlayLevel: [deploy] Created deployment server.
LogPlayLevel: [DD] Trying to connect to mobile device running iOS …
LogPlayLevel: [DD] Mobile Device ‘iPhone de Vinicius’ connected
LogPlayLevel: Failed to connect to bundle ‘com.setegames.teste’ with Unknown error 0xE80000B7
LogPlayLevel: [DD] … File to be written ‘/Users/vinicius/Documents/Unreal Projects/teste/Saved/StagedBuilds/IOS\iPhone de Vinicius_Manifest_UFSFiles_IOS.txt’
LogPlayLevel: [DD] … File to be written ‘/Users/vinicius/Documents/Unreal Projects/teste/Saved/StagedBuilds/IOS\iPhone de Vinicius_Manifest_NonUFSFiles_IOS.txt’
LogPlayLevel: [DD] … Error: Failed to connect to bundle ‘com.setegames.teste’
LogPlayLevel: [DD]
LogPlayLevel: Exiting.

I am unable to post a review of my games because of this problem. Does anyone know how to solve it?

Does anyone know how to solve it?

Hi there. I ran into this problem and I fixed it by using another iOS device. After attempting to launch the .ipa file through XCode it complained that my device did not have a compatible CPU.



Thank you so much for help me. O will try to use a newer device.

I have a newest device but it not work for me.

Ok, workaround above does not help me.
I found another solution:

Precondition: You should have valid cert imported.

Nav to Project Settings->iOS, there is Build tab.
There I checked “Automatic Signing” checkbox and added valid iOS Team ID (you can find it [here][1])

After that I was able to deploy my project.

Why there is no Automatic Signing checkbox in my UE4.20 Project Settings->iOS->Build? Not in a new project too.
There is only a Remote Build Options there.

What version of ue you use?
I’m using ue4 4.20.

I didn’t see any Automatic Signing checkbox in my UE4.20


How did you got that?

I’m surprised Epic still has yet to fix this stupid bug. I reported this a year or two ago but it fell on deaf ears.

The solution is to not be using iCloud Drive while working on this project. If you saved this project on a folder that uploads to iCloud drive, you’ll run into this issue.

Best to turn off iCloud Drive syncing of Documents/Desktop folders before you begin your project. If you already have the project in Documents, move it to your local drive that doesn’t get sync’ed to iCloud and then run this command:

xattr -lr (path to .app bundle)

For me this was

xattr -lr

Then run your build again.

see my answer below.

see my answer below.

THANK YOU! This was very helpful. I created a new version of the project on a par of the drive that does not sync with iCould and then was able to successfully launch to my iOS device.