Fail to compile latest "4.3" source

Like the master source the latest 4.3 source also produces a bunch of errors

Error 5 error : Failed to produce item: D:\DO_NOT_ARGUE\GAMES\UE4\SOURCE\4-3\Engine\Binaries\Win64\UE4Editor-ShaderFormatOpenGL.dll D:\DO_NOT_ARGUE\GAMES\UE4\SOURCE\4-3\Engine\Intermediate\ProjectFiles\ERROR UE4

Error 2 error LNK1120: 1 unresolved externals D:\DO_NOT_ARGUE\GAMES\UE4\SOURCE\4-3\Engine\Binaries\Win64\UE4Editor-MetalShaderFormat.dll UE4

Error 4 error LNK1120: 1 unresolved externals D:\DO_NOT_ARGUE\GAMES\UE4\SOURCE\4-3\Engine\Binaries\Win64\UE4Editor-ShaderFormatOpenGL.dll UE4

**Error 1 error LNK2019: unresolved external symbol "int __cdecl HlslCrossCompile(char const *,char const *,char const *,enum EHlslShaderFrequency,class FCodeBackend *,struct ILanguageSpec *,unsigned int,enum EHlslCompileTarget,char * ,char * )" (?HlslCrossCompile@@YAHPEBD00W4EHlslShaderFrequency@@PEAVFCodeBackend@@PEAUILanguageSpec@@IW4EHlslCompileTarget@@PEAPEAD5@Z) referenced in function “void __cdecl CompileShader_Metal(struct FShaderCompilerInput const &,struct FShaderCompilerOutput &,class FString const &)” (?CompileShader_Metal@@YAXAEBUFShaderCompilerInput@@AEAUFShaderCompilerOutput@@AEBVFString@@@Z) D:\DO_NOT_ARGUE\GAMES\UE4\SOURCE\4-3\Engine\Intermediate\ProjectFiles\Module.MetalShaderFormat.cpp.obj UE4

**Error 3 error LNK2019: unresolved external symbol "int __cdecl HlslCrossCompile(char const *,char const *,char const *,enum EHlslShaderFrequency,class FCodeBackend *,struct ILanguageSpec *,unsigned int,enum EHlslCompileTarget,char * ,char * )" (?HlslCrossCompile@@YAHPEBD00W4EHlslShaderFrequency@@PEAVFCodeBackend@@PEAUILanguageSpec@@IW4EHlslCompileTarget@@PEAPEAD5@Z) referenced in function “void __cdecl CompileShader_Windows_OGL(struct FShaderCompilerInput const &,struct FShaderCompilerOutput &,class FString const &,enum GLSLVersion)” (?CompileShader_Windows_OGL@@YAXAEBUFShaderCompilerInput@@AEAUFShaderCompilerOutput@@AEBVFString@@W4GLSLVersion@@@Z) D:\DO_NOT_ARGUE\GAMES\UE4\SOURCE\4-3\Engine\Intermediate\ProjectFiles\Module.ShaderFormatOpenGL.cpp.obj UE4

Error 6 error MSB3073: The command “…\Build\BatchFiles\Build.bat UE4Editor Win64 Development” exited with code -1. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets 38 5 UE4

Hi KillerSneak,

When you downloaded the source for 4.3, how were you getting it and the dependencies for it? Were you synching to that branch in your repository, or downloading the zipped source? If you were downloading the zipped files, were you getting that from the main page on GitHub, or from the Releases page?

I just spent a little time doing some tests downloading and compiling the zipped versions of the source for 4.3, and I was only able to trigger an error message when building (LNK2019: unresolved external symbol) when I used the wrong dependency files. Are you certain that you are using the correct dependency files for 4.3 (the dependencies for 4.2 won’t work in 4.3)?

Hi ,

I have the 4.3 branch synced with TortoiseSVN so I can get the latest build/branch when ever I need to. The dependencies for 4.3 I got from this page as described,
#1 -
#2 -

Same goes for master I have it synced with TortoiseSVN so I’m able to pull the latest version/commits when needed. The dependecies I got from this page for the master build
#1 -
#2 -

I’m sure i got the right dependencies as you can see from the links above.

Please correct me if I did anything wrong.

Most likely the 4.3 branch is now out of sync with the dependencies. The only safe time to grab github source and dependencies right now, is when Epic so and official release. Like one of these:

There is a new release on there for 4.3 right now and it is 23 hours old, so give those dependencies a go or just grab the source archive :slight_smile:


I tried it all, I got the right dependencies. You can not mix and match dependencies as far as i know. Master and 4.3 can not share dependencies.

Got the same issue, cannot build.

See this post: Build of master on Windows fails: HlslCrossCompile undefined - C++ - Unreal Engine Forums

thanks @jCoder, that did it. :slight_smile:

I see the post but what does it say? Do we need to keep using the latest preview dependencies files even while EPIC specifically says not to? I told/asked them the same thing several times and they told me that each branch needs it’s specific dependencies. So master only works with master dependencies (ones i linked) and same goes for 4.3

Until a staff member from EPIC can clarify this i don’t think we can accept your post as a answer?

Thanks, I’m trying to build the master source now with the dependencies from the “latest-preview”

Doesn’t work for me still getting a ton of errors

The post I linked to is from an Epic employee. He confirms the issue and the solution.

Are you going to the link mentioned in the page listed? Like this one: If not, that is your problem. You need all the files posted under "Unreal Engine 4.3.0 preview build " and the choice beween Linux and Windows. Windows: Just unpack them all in the same folder, double click on “GenerateProjectFiles.bat”, then open “UE4.sln”. Select “Development Editor” (x64) and right click on “UE4” in the “Solution Explorer”, and you should be set to go without error. It needs to be built first. If you still get issues, check the pre requisites, that all is in place.

Hi KillerSneak,

The dependency links that you show for 4.3 should work. I started over again today with a completely new repository for UE4, and was able to get the 4.3 Preview version to build successfully with those dependencies. Are you still seeing the same errors when you try to build 4.3?

Edit Also, the dependency links for the Master branch that you provided are incorrect. Those are actually pointing to the dependency files for version 4.1.0. I have reported the error in those links and we should have it corrected soon.

Edit 2 I just checked the Readme for the Master branch, and the links to the dependency files have been corrected. However, these dependency files may be a few days behind the Master branch, so you may still run into errors when trying to build the Master branch.