Fade out Particle Emitter Spawn Rate via Blueprint

Hi there,
I’m not getting some fundamental aspect of assigning values to Particle Emitters (and probably other objects, too). I’ve created a pretty nice looking particle system that activates and positions itself when the left mouse button is pressed. When Released, I used to just destroy the emitter and, while that was OK, I’d prefer to have the particles fade out prior to destroying the emitter.
I’ve created a timeline that nicely fades from 40 to 0 when the LMB is released in .5 seconds – I added a print function to confirm at one point – but I’m not getting how to apply that value to the particle’s spawn rate or instanced parameter.
Any suggestions are greatly appreciated.

There are a couple of steps that need to be taken:

Firstly, you need to set the spawn rate scale in cascade to a float parameter. (Specifically, distributionFloatParticleParameter).
Then, in your blueprint, you need to use “Set Float Parameter” for the particle system, and pass in the name of the parameter defined in cascade. See attached for details.


you can also just use a deactivate on your particle system. If you destroy your emitter it removes the effect and your particles pop out. If you deactivate the emitter it waits for the particles to finish their lifetime, and then cleans up the emitter.

That does seem like an easier solution to the OP’s issue, although he should probably learn about parameters anyway! :slight_smile:

Might this solution broken in UE 4.12.5?
I can’t seem to expose any parameters that are floats (both Spawn Rate and Rate Scale) but Initial Velocity works as documented.
Anyone else seeing this?

I’m getting unexpected behavior in 4.12.5 too. Problem: I can set the spawn rate to 0, but then can’t reset it back to 1 later.

The way you do this is you can reference your particle system like shown above call spawn float parameter on it and then make sure the parameter name is exactly how you typed it in the particle, and also MAKE SURE YOUR MIN VALUE and MAX VALUES are optimized correctly if you want a range between min 0 - max 7500 particles then you can increase from 0 to 7500 or decrease from 7500 to 0 particles using lerp or timeline or any other methods of incremented values or decremented values.