Factory Floor patchy

Hey there just starting on my factory UE4 project and just wondering if I’m missing something, ie this is just a simple floor static mesh made in Blender with 2 UV maps, placed the “rough_concrete_with_lines” Graph on it in Substance Designer, then imported all into UE4.

When I build the lighting quality at “Production” I’m still getting what seems to be seams, and patchy lighter and darker versions of it. Am I doing something wrong?

Here’s a closeup of what I’m talking about…

I tried a checkered pattern on it too and it looks like this…

I guess I’m envisioning problems when it comes to the walls, ie I’d like to have them as modular, because some will have windows and some won’t etc.

ie in World of Warplanes would they have set their modular walls and roof up like where I’ve highlighted?

Is there tutorials that could help me out in this situation?

Thanks in advance.

It sounds like you’ve done the texturing in blender. It’s often best practice to do the UV mapping in the 3d modelling software and do all the texturing in Unreal. I would make sure your UV maps are nice first. I typically do a single box map for surfaces like this. You could then create your materials in unreal, making sure you make a good tileable texture and normal map.

Those seams could also possibly be the result of a lightmap setting that is way to low (but much less likely than a texturing problem). You could try increasing your lightmap resolution. If that doesn’t work then your best bet is to do re-uv mapping and make the textures in unreal.

Hey there tedshrop,

I do the UV Mapping in Blender, texturing in Substance Designer, and then jump into UE4.

And I’ve tried upping the lightmap resolution but that doesn’t change things either…

Well in the end I followed this tutorial "Baked Lighting" and "Lightmaps" (Maya & Unreal Engine) - YouTube (but didn’t really change my UV setup), I did notice when importing my mesh I had “Generate Lightmap UV’s” & “One Convex Hull Per UCX” on, so I turned those off. I kept my Mesh “Min Lightmap Resolution” & “Light Map Resolution” as 256. And changed my World Settings for “Static Lighting Level Scale” to 0.1 & “Indirect Lighting Smoothness” to 2.

Are any of those settings going to be inefficient, anyhow I got this result…