Facing a Problem while building UE4 on Ubuntu 20.10

I am trying to build UE4 on Ubuntu 20.10. I have cloned the GitHub repo and run the Setup.sh file successfully as per the instructions given.But when I run GenerateProjectFiles.sh, i get a bunch of warnings as shown in the screenshot below.

Also, after running this,when I run make command,I get an error as seen in the 2nd Image.


I am stuck at this step for hours and can’t figure anything out.I trying running the SetupToolchain.sh again but it has already installed successfully.

What should I do so that I solve this error?I also googled for tutorials and fixes but couldn’t find anything.

Specs :

Hello, can you be sure to check what github branch you synced was to the release branch and not the master branch?

Also make sure Engine/Build/BatchFiles/Linux/SetupToolchain.sh ran, which should place/download that SDK: Engine/Extras/AutoSDK/HostLinux/Linux_x64/

I have cloned the Release Branch, I checked it again.

Also,I checked the Engine/Extras/AutoSDK/HostLinux/Linux_x64/ folder,it is showing the following folders, all of them have setup.sh and unsetup.sh files within them.

Is something that I am doing wrong?

Hello Neeraj,

I have gotten those very same errors a couple of times before. I am not sure how it happens but (maybe inconsistent file state after a failed build?) I followed Michael Sartain’s instructions here to refresh the git repository without completely re-downloading it solved it for me. Also, try not to run the setup and build commands all on one line like so:

./Setup.sh && ./GenerateProjectFiles.sh -MakeFile && make

Instead break them up one-by-one. I found I was getting a command line prompt during ./Setup.sh but was unable to answer it and that messed up the ./GenerateProjectFiles.sh step. I hope this helps.