Download

Eyes are almost outside body on animations

The imported 3D models are OK. However, after animated, this happens to the eyes:

It’s not a problem about translucency.

The eyes are almost outside the body, but just when animated. It’s a Mixamo character, and this happens only when we added a root.

We have two versions of this character, one is the enemy, original Mixamo model, without root. The animations works fine.
The other is the same model, but root is added in Blender and this problem happens. Weight painting is OK.

I guess there is some wrong setting on model or animation, but I don’t know if it’s some importing or export setting on Blender or Unreal.

P.S.: My real life eyes was like this after I found this bug was happening.

Are the animations authored on a different sized skeleton? If so, check retargeting settings on eye bone - eg Skeleton, Animation, Animation Scaled, etc…

Are the animations authored on a different sized skeleton?

Yes.

Thank you. That’s the problem.

The original skeleton have eyes on a different place, but I don’t use retarget because they have the same Skeleton Tree. I’ve used retarget before, but I’m not good at it, so I just use it when it’s extremely necessary.
I always make a backup of the project before retargeting because sometimes I make a huge mess while retargeting and have to use the backup file… lol

I will study and research more to learn the right way to fix it.

The way I will fix it now isn’t the right way, but I haven’t too much time, and I think it will work:

We will make the eyes become a mesh, part of the 3D model on Blender, so the bone will have no influence on the eyes. As the eyes aren’t animated, it will not be a problem now, but on future games we will learn how to fix it.

I think you misunderstand Odenir. The retargeting setting that OptimisticMonkey refers to decides what happens when you play the same animation on two skeletal meshes with the same skeleton. In this case, you don’t want translation to ever happen on the eyes. Which means that you can set retargeting to Skeleton. (that is, keep the eyes in their original exported position) You pretty much have to do this if you are to use multiple characters with different proportions but the same skeleton.

Just open your skeleton asset, show the retargeting menu. Find your eyes in the list, and change their retargeting setting to Skeleton. Takes like 1 min.