Eye Adaptation Not Working. Going in Reverse? (UE 5.0.2)

Hi all the Auto Exposure category is driving me insane. It seems that it thinks my dark area are bright areas and my bright ones are dark.

Below is a screenshot the Auto Exposure staring in a dark corner with my default settings on histogram. (I have lit the areas around it and there tends to be glow around the edges of the dark.)

As you can see it is going into the red heat zone on the HDR (eye adaptation) window.
Which then darkens the rest of the scene. If I use Auto Exposure Basic, this problem goes away but then I get no adaptation. Does anyone know why this is happening and what I can do to fix / avoid it in the future?

I know I can lessen the effect of the darkening by playing with the numbers but it still doesn’t solve my overall problem that things are going in reverse and I have no idea why.

Hi @PotionDweller! Welcome to the forums!

First thing I noticed was that your exposure compensation was set to -1 instead of 1.

Was that changed intentionally? If not, I would change that to 1 and test the result.

I hope the solution above works for you!

Ah I should have mentioned that.
Yes that was changed to darken the scene a little bit. According to the reference guide negative darkens slightly and positive brightens.
Even when at 0 or positive values doesn’t correct the issue sadly. The temperatures are still totally reversed for what is expected.

Hey @PotionDweller!

Okay, so to narrow this down, does this effect happen with with eye adaptation disabled? What about outside of your post process volumes? Does it return to normal?

If you create a new post process volume in a new level, does the effect still remain?

What does your scene look like using the Histogram Debug Visualization mode (r.EyeAdaptation.VisualizeDebugType 1)?

Are there any altered post process effects you are using?

Any additional info about your post processing and/or rendering would be a big help!

Hey @Quetzalcodename thanks for helping me out with this.

I was initially noticing this issue before putting in a post process volume into the scene and added one with an infinite extent as an attempt to adjust it.

Below is a photo of the Histogram in Debug without any post process volumes enabled

A sea of red for the dark areas and a few blue / white spots where lighting is added into it.

As far as I am aware I haven’t adjusted any settings to the defaults of UE 5 this should be out of the box I don’t have raytracing enabled.

While using a post processing volume the only other setting I adjusted within the default box I added was adding a slight amount of bloom to torches, but this was after the initial issue was noted.

Things that may be of worth note:
This project was made using the first person starter, C++, Desktop, with content, no raytracing
The level I built was made with a new empty level

  • I do not have a direct light source in my world only a sky sphere because everything is enclosed inside.
    E: even with a direct light added I still seem to get the shadow bleeding issue.

  • The assets I am using for the game are from the free Medieval Dungeon provided by Infuse Studio on the marketplace.
    Found here:
    Medieval Dungeon in Environments - UE Marketplace

( I am starting to suspect the issue may be with these assets as they were not updated beyond 4.22, but not entirely sure.)

Hey @PotionDweller!

That is a lot of red, maybe more than should be there but that’s not totally abnormal since your scene is supposed to be dark. So you are correct that the assets may not be compatible with 5.0 and trying to port forward may be the issue. Also, have you tried disabling ambient occlusion and seeing what happens?

It may be the assets need to be replaced or imported again.

No luck with the ambient.
So I played around with some basic levels in the editor. I made a new level with empty level settings and threw down a quick box with standard checkered mesh and a few torches inside issue persisted.

Did the same with a basic level and tried as well out of curiosity. It seemed to behave better with adaptation but I still noticed that even if I was in an area where light was being emitted from and I stood in front of a light facing away from it things went pitch black.

So I am really confused. I knew there should have been light in front of me or at my feet but nothing was showing.

Tomorrow when I have more time I am going to make an FPS starter project and see what happens in the default level when I make a closed space and add some lights.


Sorry for the delay weekend was busier than I thought. I got a chance to play around with materials and made a recording but I think I have a better understanding of what is going on now but not sure what I can do to fix this…

It appears to be material related. I made a demo box in the FPS default level.

Two boxes really. One with basic shape material and one with default materials.

Default materials turned pitch black the second I looked away from the light source even if it was illuminating the floor beneath me.

Basic shape materials would reflect and bounce the light around a lot more and light would adjust like I expected.

Any ideas what material factor may be causing this that basic shape has that default material doesn’t?

1 Like

Hey @PotionDweller!

That narrows down what could be the issue be a lot, though, that is extremely odd. By default materials, do you mean from the dungeon assets?

If so, would you mind sharing one of the material graphs of the assets you are attempting to use?

Also, do the dungeon assets work as intended without the materials applied?

Hey @Quetzalcodename
For the static meshes the materials on them are what I am referring to and default materials in the FPS tutorial after disabling the post process volume.

Example I made an inclosed tunnel using the default SM_Cube and SM_ChamferCube

On the right hand side You can see the Materials category.
If I double click on Element 0 I am greeted with this MI_PrototypeGrid_Gray

What I noticed between this material and the other one is there is no Color category where I can adjust the V Value as seen with the MI_Solid_Blue

The higher the V value the more the light seems to bounce making it actually adapt in the dark.

If I look at the Grey grid floor in this tunnel everything goes pitch black. I am guessing the V value for it is 0.0

As I get a similar result when I change the blue V value to that

Trying to figure out if there is a way to adjust those values at all. Or at least figure out if I can add this to things.

I noticed with my dungeon the Materials looked like this:

Even then I’m not 100% sure this is the cause but its my best guess as it seemed to fix it.

You should be able to replicate this yourself at least seeing the darkening effect if you make a room out of the SM_Cube and look around with a point light behind you and the post processing volume disabled in the FPS default map.