Download

Extreme lag with grass

So I bought the grass pack from the market place and it’s amazing but i’m having some trouble with it, i’m creating a really big environment which will need a lot of grass, trees etc. I was reading other threads that said that disabling wind effect could help I have done this and it has helped a bit but no where near what I need it to be. Any suggestions?

Thanks!

-use culling
-use hills and other stuff that blocks the view of the player
-decrease the placed amount of grass (with a good ground material you can get the same good result)
-decrease the tri count -> a good grass mesh can be just made with two planes (6 tris) :wink:

Thanks for the tips, sorry for being a mega noob but what are “tris” and how would one go about changing these? :slight_smile:

Also, if you’re not using the Foliage tool then you must–it can allow many many objects to load for grass and have as best of performance as you can get.

A tri is a shape in a 3d program. Better explanation: http://en.wikipedia.org/wiki/Triangle ^^

e.g the part in the red box is one tri -> so the plane on the picture consists of 2 tris

tri.jpg

The grass from the marketplace has around 100 tris which is pretty much for a simple grass mesh -> you can easly decrease it to 6 tris. Therefore you have to modify the mesh in your 3d program.

e.g grass with just 6 tris (a picture of the prototype from the foliage package that I will put on the marketplace :)):

cdbecccb9c55c781429ddc2fed2c76c6b15338c2.jpeg

I am using the foliage tool, going to have a play around and see if i can improve it

Thanks for the in depth answer!, I’m still very new to everything so I’m learning everyday with terminology and techniques etc :), I have blender so I will go into in now and see what i can do

Also your grass is very nice, am I correct in saying that you will be submitting this to the market place? it’s awesome :slight_smile:

Should be pretty easy. Otherwise just post another thread when you have any problems :wink:

Yep, I will try to get it on the marketplace when 4.7 is released -> rough overview:

Meshes:
-12 Grass
-12 Flower
-10 Trees (under 3000 tris)
-6 Bushes
-6 Field

Materials:
Two master materials and several material instance constants which will allow you to add various effects. There are three different categories of effects:

basic: wind
advanced: wind, texture variation depending on the position of the mesh (upper picture includes that -> so a random colour)
pro: wind, texture variation, snow, swaying (trees), winter (tree - no leaves), autum, (tree - autumn colour), interactive with the player (when he walks over those meshes, they will sway)

Everything just for 15$ :slight_smile:

Hi sorry one more thing, so I’ve imported the grass mesh into blender, I’m currentl watching a tutorial of how to change the tris, once I’m finished I export out and import into unreal engine 4 and add materiel, is there anything else I would have to do?

You will have to delete the tris so that the grass still looks good -> so you will probably have to modify the uv’s or the position of the planes (I cant guarantee that the grass will still look good after you have modified it -> could be that the texture isn’t so suitable for a very low poly mesh ;))

When you have modified it, you just have to import it again + assign the material.

Also check if it’s true that one of those meshes has over 100 tris (I just saw it on the marketplace ^^) + if he probably uses LOD’s!! (havent bought this package, so I cant check it)

okay so I’ve run into more problems I reduced the tri by using the decimate modifier I exported it then imported to ue4 but it popped up with an error about the smoothing groups, I had a play around and then exported and imported, i then placed the mesh but the tris haven’t changed? and I can’t resize the mesh either?

-dont use the decimate modifier -> it’s better to do it manually :wink:
-otherwise when you want to use the decimate modifier, make sure that you press “apply” after you have changed the values
-smoothing -> on the left side of the screen you should find a “smooth” button. When this doesnt work, take a look at this page: http://wiki.blender.org/index.php/Doc:2.6/Manual/Modeling/Meshes/Smoothing

But as I mentioned, first of all check if they probably have LOD’s ^^

Make sure the shadows are OFF in the foliage tool. I did the same and got serious lag. Then I noticed each instance was throwing shadows. This puts too much stress on the computer. You might have to click on the little arrow at the bottom side if the foliage tool to see the lighting/shadows options.

Okay so I’ve tested it a bit but I’ve noticed it looks very cardboard like from above, here is a screenshot.

c5244c5b6be16bcf5fdf31a66504c12a212077cf.jpeg

That’s very common for using planes for grass. If you’re using 3ds Max, you can use a bend modifier so that the grass provides some cover for the planes, or you can angle the planes like / or \ so the planes are less of an eye-sore.

Or you can just create grass that looks like that (either with 2 planes or 2 tris -> red lines) :

gra.jpg

hi, sorry me again :stuck_out_tongue:

I’m trying to move the planes separately but they appear to be not a separate mesh? or at least appear that way if that makes sense?

It’s one single mesh, but in edit mode you can move them :slight_smile:

I’ve decided to do the grass like above, I have to planes but I’m terribly sorry I don’t understand or know how to get those red lines?

The red line just demonstrates that you can either use 2 squares or triangle planes :wink:

2310840da7aa74ffeb0ce414c5d50b367fe47690.jpeg