Download

Exterior/Interior Lighting Issues

Hi

I am having issues with Exterior/Interior Scene. (Please see attached Screenshot).

I cannot get the right balance of interior/exterior lighting. Exterior is too bright, interior too dark.

I am using Skylight, Directional Light, No point or Spot lights, Lightmass Portal over Sliding door.

I am trying to light the scene as naturally as possible.

Auto Exposure is turned off under Project Settings, Renderings.

Auto Exposure is turned to Automatic under Lit/Exposure.

Post Process Volume Settings - Auto Exposure - Min Brightness 0.5 , Max Brightness 2.0, Exposure Bias - 2.2

World Settings - Lightmass Settings:

Static lighting Level Scale : 1.0
Num Indirect Lighting bounce: 20
Indirect Lighting Quality : 10
Indirect Lighting Smoothness: 1.0

I have left Baselightmass.ini file as I was told because of Lightmass Portals you don’t need to change these settings anymore.

I have watched so many tutorials but just cannot get the balance right.

Any help would be much appreciated.

Thanks
Graeme

This is tricky. You will always have the interior dark and the exterior bright. It’s about finding the right values for each scene and there is no easy answer that fits all situations. Here a few tips.

  • the higher the brightness of the directional light is the harsher is the difference between inside and outside. Try to set the sun brightness lower, around 3-4 maybe if you have it higher.
  • when everything outside is white then the adaptive brightness balance will make the inside look darker. Add a few trees, buildings or a large ground mesh so the outside horizon is a bit darker.
  • 0.5 as min brightness might be too high. Maybe try 0.1 and then set the exposure bias lower, between 0.5 an 1 as a start.
  • you can have multiple post process volumes on top of each other. You could add another one for the inside with higher priority and different settings. The value from the volume with the highest priority will be applied. The camera counts here not the object. Wherever the camera is it will pick the volume with the highest priority. Doesn’t matter if the meshes are in the volume too as long as the camera looks at them.
  • as a last resort add a low brightness large radius static light in dark corners. Make sure you build lighting as those lights will look totally different with or without lighting built.
  • add a lightmass importance volume to the scene

It might just be too difficult at this angle. You cant have half of the image adapt differently than the other half. Some people start with min/max 1 and then adjust the bias but I haven’t tried it that way.

Obviously having a white exterior and darker interior is amplifying the issue.

You can try the Lightmass: multi-bounced sky lighting to help lighten up the dark spots in the interior Lightmass: multi-bounced sky lighting - Unreal Engine Forums

Playing with the tone mapper can help.

Thanks for the feedback and assistance, I will try your suggestions S_dot. If I can’t get it right, I think I will just turn everything down and use static point lights to light the interior.

ZacD, I am already using Luoshuang’s Lightmass file and increased my light bounces, still dark though. I will try the tone mapper as well, thanks.