Exporting TPV files for import/export custom weapons

I followed FancyFlannels’ EXCELLENT tutorial here:

Which worked PERFECTLY for the FPV models. However, I have exported the metal axe, spear and pick TPV rig files, and when I import them into a (trial version) of Maya 2016 it errors, saying that there is a missing skin cluster. If I follow Flannel’s tutorial, I get to binding the skin to the for example “spear_jnt” and then it errors, saying I have not selected a joint (despite having them selected.) Which means I cannot weight paint the TPV rig or use it.

Has anyone else imported custom TPV assets, and if so how did you do so???

Just as an overview I remember it going like this:

*select object in representation liner
skin -> detach skin

Delete metal axe

Ungroup skeletal system

Open hierarchy

Import new obj

Place it correctly

Freeze values

Select all Hierarchy, mesh first though

Bind skin options blah blah

Brush tool thing with only mesh selected

Select Hatchet_jnt in brush tool and flood it. Flood everything else black (value = 0 for black)

Select mesh and export using settings (animated turned off in this case, triangulate on, group smoothing on etc)*

Now quick question, when you are importing the new TPV mesh inside maya, are you using an .obj file or an .fbx file?

I recall having the same issue when I was trying to replace the hatchet with an .fbx file. Perhaps this is the issue as I’m not aware if the same process needs to occur or perhaps using slightly different settings.

Get that out of the way first

I export the TPV file as an FBX; i did everything up until freeze values. The new mesh I’m importing is an OBJ file. When I import the TPV fbx file, there is only ONE “name_jnt” file, and when I try to bind that to the new obj mesh, it says no joints are selected (despite both being highlighted before I opened up bind skin)

The ark dev kit won’t let me export the TPV files as anything OTHER than an fbx file— unless there is another resource I haven’t seen yet for TPV files =/

Hi dartuche,

I’ve had this same issue for too long, but I was finally able to import the tpv. The difference was I made the tpv by using the maya source rigs that they recently released, located here: M:\Steam\SteamApps\common\ARKDevKit\Model And Animation Sources. The thread on it is ARK Dev Kit Update Notes! (Current: 222.6) - ARK: Survival Evolved - Unreal Engine Forums

That did the trick for me, good luck!


OMG that worked perfectly! By directly importing the maya file for the TPV file, I was able to get it working yaaaaaay! Thank you so much!

Excellent! I’m happy it worked for you too. I was banging my head against a wall for way too long, but those files made all the difference. Feels great.