Download

Exporting/Importing apex cloth problem

Hi,

I am trying to create a simple flag using the apex cloth plugin in Maya, but cant seem to get it working.

It animates fine in Maya when I test it, and I have exported the FBX file with no problems. But when I try to export the cloth as a APB/APX, it saves as a .pxproj and unreal cant seem to find it. I have looked at tutorials and follow as they do but it just isnt working for me.

Here is a screenshot of the maya file, while the outliner

ed64486063d27eb31abedec83bda98213a5f4487.jpeg

Here is what its saving as, with a a VLC file for some reason.

53e9b57ff3f22d88bc57571ef56bccee5165aff2.jpeg

How do you export + import your cloth asset? :slight_smile:

e.g https://www.youtube.com/watch?v=oRaStTw0-l0

Perhaps you could post your export settings? These are the settings i’ve used (Maya 2015) and it works fine without any issues. Perhaps it fixes your issue.
b0df2a0e5a2d414a2a06df15bce993ff62e71089.jpeg

I followed that tutorial with the skirt, for exporting im just selecting the cloth part and exporting only that.Ive copied your export options but it still doesnt seem to work.

3.jpg

im using the" add apex clothing file" button when importing.

Have you tried exporting all rather than exporting the selection?

yeah, just tried redoing the whole thing and it still doesnt work. Its something to do with exporting the APB/APX file, it just doesnt make the file properly and is only like 2kb in size, where as on the tutorial his is much larger

Hmm, really strange. Normally when you follow one of the tutorials (e.g official ones) it should work. Have you already tried to use an older version of apex?

tried doing it in Maya 2013 instead of 2015 and its the same problem. Must be doing something wrong but don’t know what

Which version of apex are you using?

2015 I used 3.0.2 and i used 3.0.1 for 2013

When you say it doesnt make the file properly, the .PxProj doesnt need to be larger than 2mb. You should have a .apb file that gets created too and that is the file you import into Ue4, but i dont see that in your list of files?

yeah, its making a VLC file instead for some reason