Exporting from 3dsMAX to Unreal Size Differences


I apologize if this has been posted and answered before, but I"m honestly stumped. I work for an architectural firm and we are gradually incorporating Unreal into our pipe. It’s fairly standard practice to model in feet with decimal/fractional inches as we are located in the states but there is something wrong when I import to Unreal. I’ve tried looking through the threads and have found a similar answer being that Unreal uses centimeters as it’s standard unit of measurement, which is what I’m basing this information on.

I created a BSP box with an X dimension of 10027(which should work out to 329 feet, and a Y of 9022 which should work out to 295 feet. I’ve created another BSP box with an X dimension of 169926 which should work out to 5755 feet and a Y dimension of equal size.

As you can see from the image posted, the units match up, but when I import the same fbx file(represented by the green landscape) it comes in at a much smaller size. I’m quite stumped as to what conversions I need to do to make sure that it comes in at the correct size, or do I just export the fbx as feet and hope that it converts properly to centimeters when it comes in to Unreal and build the BSP boxes off of that?

I feel like I’m missing something here, especially since I’m using a heightmap to generate a landscape(which I’ve no idea how to convert to the correct size beyond scaling it to match the geometry the heightmap is derived from.

Any and all assistance would be appreciated. Thank you so much for any help you can give.

Have you tried resetting the xForm of the meshes before exporting?


Yeah, I had reset the xform, unified the normals/smoothing groups/ reset the uvs/ etc.

As it turns out, the issue was in the export options. I hadn’t turned off automatic conversion in the units section. I had to switch that off and select centimeters.

I really appreciate the time you took answering the question though. Thank you so much.

Good to hear it’s sorted!