Download

Exporting from 3ds Max with Materials

hey Guys,
I just tried to export some simple objects for testing into UE4 and i recognize the materials which i applied in 3ds max to the object are missing…
Is it even possible to export the object with simple “Color” materials “informations” into UE4 ?

I exported with FBX, with a reg blinn mat applied and it imported just fine. Make sure you have materials and textures ticked on export and import.

When i’m exporting an object from 3ds Max by export selected there is no option in the FBX exporter which says Materials / Textures …
I’m exporting the objects as autodesk 2013 FBX ASCII ther are also some other options but nothing about materials and textures ?

No one knows what i’m doing wrong ?

Have you ticked “embed media” ?
I normally use “binary” when export.

No “embed media” is not ticked but i will try it right now :slight_smile: I will also try binary instead of ACSII…

Also, make sure you have an apropiate UE4 format for your textures like PNG or TGA
For Multiple Materials take a look at: https://docs.unrealengine.com/latest/INT/Engine/Content/FBX/Materials/index.html

I wouldn’t bother with exporting materials really. And it doesn’t export colour information from the material in Max, only the textures as long as they are in the right format.

ah ok, thanx! so simple color inforamtions can’t be exported as a material, many thanx!

Actually setting up materials in max may be a great time saving thing… Doesnt have to be anything special. However say you have a vehicle. all pieces are one combined mesh. If you use a multi/sub object type material. Unreal will import these material layers as materials/channels. then just edit they layer and it changes on the mesh… I just finished a tut im doing for my teams projects on this very subject… Ill go ahead an put it up and show you what i mean…Ill link it as soon as its done uploading

here ya go nothing super special as it was actually meant for my teams archives but it shows what i mean

https://www.youtube.com/watch?v=Px-PHtLfCXs&feature=youtu.be