Exporting BSPs to FBX file not working

Hi everyone,

I have a problem getting BSPs working when exporting to FDX. I am trying to export these BSPs however my file in max is empty when I import it.

Any advice for what could be causing the export to fail? I am using additive and subtractive voulmes,

Have you already tried this way → convert it to a mesh (in the details panel - create static mesh) - export it from the content browser :slight_smile:

unfortunately, when converting to static mesh before, strange things tend to happen.

E.g. When converting a selection of brushes (below) it then they appears to remain in the perspective window, but in any other windows they have vanished. Soon after the brushes will then appear at the world center of 0,0,0

No static mesh is created in the content browser.

When converting a singular static mesh, it just vanishes from the map with no static mesh created.

It’s all rather strange.

I have tried exporting the selection of brushes without the top subtractive brush as well, the same thing happens.

I tried this and I have exactly the same problem. It makes LD and LA process a bit hard at the moment…

Hi Elgreeno,

I’ve tried replicating your issues with BSP but have not been able to do so thus far.

I created several BSPs with a subtractive and these have exported without need to convert to static mesh first. I’ve also tried looking at your other issue with the views, but have come up short there as well.

I’ve tested all this with the 4.6 version of the editor. Which version are you currently using? Also, for the sake of making sure I’m not missing any steps can you list your exact repro steps and I’ll see if I can get the same results on my end?

Thank you!

Tim

Hello Tim,

After a fair bit of playing about I have 100% repro.

I am using version 4.6.1. WIth Perforce linked to Assembla.

I just tried to export a spiral staircase in BSP (just a drag and drop staircase BSP brush) and it worked fine (export was 20k and max opened it up fine).

It appears to be an issue of placing the BSP. Saving the map and checking out the files. Then upon reloading the editor, the file won’t export anymore.

How I export.
Select all the brushes from the Perspective window (of my BSP well from the pic above)
Then File → Export Selected → .FDX
Load 3DS MAX
Select Max Icon in tool bar
Select Import
Select File name

Nothing is in the saved test scene, the file FDX is at 5k and empty.

But if I drag and drop a file and export before saving and restarting, it works fine!

100% repro. This was driving me insane.

Hi Tim, Do the repro steps work with you?

I have no way of testing this type of setup with Perforce and Assembla. I’ve looked at it a little and I am trying to see if there is another way I recreate the issue without specifically needing Assembla, but I’ve not had time to dig into it too much at the moment. I’ll continue to look into it and see if I can get something similar to happen.

i am not 100% sure the P4 and assembla are needed. Have you tried just saving a scene, re-opening and then exporting?

That was one of the first things I did. BSPs in general can be troublesome sometimes and takes a little investigating to reproduce in some instances. :confused:

I’ll keep looking though.

let me know if I can help in any way.

As a work around I am now creating a fresh copy of the saved bsp and then exporting that.

It is rather strange that for us, that when a BSP is saved it will no longer export.