Exporting animation from Blender to Unreal creates a large number of static animations

So for past day straight or so, I’ve been trying to export my animation as an .fbx from Blender, and then import it into Unreal. I’ve been Googling like crazy, but as far as I’ve seen, I’m the only one with this problem. When I import by .fbx into Unreal, it creates an unnecessary number of animations, all of which aren’t actually animated, but act as if they only have one keyframe (static).

I’ve already asked this on the UE AnswerHub, but I haven’t gotten any comments or answers, and I fear it’s been lost in the endless stream of questions. I figured I might as well ask here and cover all my bases. The AnswerHub question includes my import and export settings.

What am I doing wrong? What should I change to import my animation correctly? Any help would be greatly appreciated :slight_smile:

In addition to the information provided in the AnswerHub question, here’s what my Content Browser looks like after I’ve imported by .fbx:

And here’s my .blend](https://dl.dropboxusercontent.com/u/56274235/Pastebin/garand_idle.blend)
For reference, I’m using Blender 2.74 and Unreal Engine 4.75.

what export settings are you using?

you might find it easier to import just the mesh/skeleton first and then import the animations 1 at a time.

Thank you for your quick reply!
So this is what I did:

  • Export everything to an .fbx from Blender

  • Import that .fbx, but deselect “Import Animations”

  • I get a skeletal mesh, a skeleton, and a physics asset

  • Export ONLY the armature to an .fbx from Blender

  • Import that .fbx with its skeleton being the skeleton I just imported

  • Now I get 4 animation sequences, but again, none of them are actually animated. They’re static.

I should also note that I’ve only set up one animation, so (if I understand how Unreal handles animations correctly) when I import the .fbx, I should only get one animation sequence.

I just tried opening your file but blender instantly closes witch means I cant test it so I am just going to wing it.

are you using blender 2.74?, I haven’t used the 2.74 exporter but it looks like they have added a new option (key all bones) witch could explain some of the empty animations, also if you leave the other settings like “NLA strips” on during export you can end up with multiple versions of the same animations witch could explain some of the extra anims, try turning the “key all bones” and “NLA strips” options off during export and see if that gets rid of some of those extra anims.

when you tried importing the mesh/skeleton first did you import the animation by typing the name of the anim in the importer, if you don’t type a name UE4 will import all anims in the file (if you have multiple anims because of what I said above that coud explain where they are all coming from).

have you tried blenders 6.2 exporter?, it sometimes works better then the 7.4 exporter.

I tried turning off “Key all bones” and “NLA Strips”, but it didn’t reduce the number of animations. I left “Key all bones” on because the tooltip said it was “needed with some target apps, like UE4”.

Where would I type the name of the anim in the importer? Is it in the animation section? Because when I deselect “Import Animations”, I can’t type anything in that field.

And yes, I’m using Blender 2.74. How would I use 6.2’s exporter with 7.4?

I got the same error when only exporting the armature.

Make sure to select a mesh and an armature when exporting the animations.

In UE make then sure that you are only importing the animation. (The import dialog should appear smaller)

Hope that helps.

hmm, maybe they’ve broken it even more, looks like I need t do some testing with it.

blender has 2 exporters in one, there is a drop down that lets you switch between fbx 6.1 and fbx 7.4

Aha! Switching to FBX 6.1 ASCII worked! Well, sort of.

I imported the .fbx as a skeleton, mesh, and animation all at once, and it created a single animated animation, like I wanted it to. However, now when I look at the animation, my gun is rotated oddly. Here’s a screenshot:

This weird offset/rotation is not reflected in Blender, only when I import it into Unreal.

at least its progress:)

is everything where it should be before you try playing the animation?

you could try clearing and reapplying location/rotation to the armature and mesh in blender and then re-exporting/importing to UE4.

Actually, it turns out the rifle was acting odd because I had forgotten to assign its vertices to a bone. I assigned them to my root bone and now it works perfect.

Thank you so much for your help! I couldn’t have done it without you :slight_smile:

your welcome:D