Exporting actors to FBX has problems with mirrored geometry

hi, whenever a mirrored actor is exported from within unreal to FBX, its orientation will mess up in the exported FBX.
often we use the box meshes to block out areas and then export these to remodel the location in 3dsmax. but when mirrored boxes or other geo is exported, the orientation is not correct.

it would be helpful if you could reset all actor rotate and scale transformations before exporting the scene.
similar to “reset xform” in 3dsmax

Hi Aphexx,

I’m not sure I saw the same results you’ve gotten with this.

Here are my steps:

  • Placed static mesh in my UE4 Scene
  • Mirrored on the Y axis
  • Selected my mirrored actor in the scene
  • File > Export Selected > Saved FBX
  • Imported in 3Ds Max.

For me everything imported the same as it was mirrored. Obviously I’m missing a step that you’ve done that reproduces this.

Let me know and I’ll look into this more. :slight_smile:


hi tim, i believe my observations were wrong. it is not mirroring but general transformations on some objects. i’ll upload this small 6.1 project. load the testboxes map… select all and export to FBX. in 3dsmax check out cubes 6,4,18,51. when you export them, they will be shifted in max.
some things are missing in the map, that’s because i ripped the things out of our project. fortunately the problem can be isolated.
thx for your time!
link text

I’ve looked at the cubes you’ve specified and I’m not seeing any difference.

I’ve taken screenshots and overlaid those in Photoshop for comparison.


3Ds Max

Overlaid comparison:

Let me know.


hi tim. that is totally weird. i tried it at home again and still got the shift.
i made an overlay picture of the wireframes

here the specifications
3dsmax 2015
unreal 6.1

here is the exact workflow:
open project, open map
“select all” with ctrl a
then “file”, “export selected”
import to max 2015

turn on left view in max and side view in unreal, then compare.
you should see a problem.
i’m puzzled

I had another quick look at this using the entire mesh rather than the ones mentioned and I’m still seeing the same results for me. I am using Max 2013 though. One of our other support team guys does have Max 2015. I’ll run a test on his version and see if there is something janky going on here.

Thanks for your patience while I look into it.


I had a chance to test this with Max 2015 and got the same results as I had previously with Max 2013.

Max Import:

UE4 View:


At the moment I’m not able to reproduce the results you’re seeing with the skewed import.

If you have any other suggestions on what I could look at to possibly reproduce I’m open to them. I’ll have to test this a little more and see if I can get this to happen.

FBX Export: [link text][4]

that is strange. currently i’m clueless why the outcomes differ. i think we have to leave this problem here unsolved. it is not crucial to me, but i really like to understand…
anyway, thanks for your time tim!

I’ve gone ahead and made your comment the answer. I do this step often when I’m doing side projects myself and blocking things out. I’ll keep an eye for anything wonky and if I find it I’ll make sure to update this post.

Likewise, if you find anything that seems likely to be the cause I’d be more than happy to continue looking into the issue and see if we can figure out something that is getting messed up. It’s odd behavior and I’d be frustrated seeing it myself. :confused:

Thanks for your patience while I was looking into it! :slight_smile:


cool, thank you tim! if it reoccurs i will definitely give an update!