Download

Exporting a skeletal mesh from blender

So I am having some trouble with this one small aspect of exporting skeletal meshes from Blender.

I created a very simple model in Blender, rigged and animated it, and exported the armature and mesh to an FBX 7.4 (Binary).

I then went to import it into UE4.6. UE seemed to recognize that it was a skeletal mesh and went ahead and imported three files, the mesh, skeleton, and the animation file, but when I pulled up the newly-imported mesh, I couldn’t see it:

I then went to import it as a static mesh instead, to make sure that the mesh exported properly, but then I found out it looks like this:

432ba3771d3dbb2c76cfc8384b918c3c2f354c1a.jpeg

It is tiny and rotated 90 degrees along the X axis. However, if I re-export the mesh from Blender without the armature, it looks like this:

69a9ef5b3866d835fdb0e784996f8655197f1a8a.jpeg

What am I doing wrong?

SCALE sorry had to write it big, that is the main issue when using Unreal engine with blender

try my blender to UE4 video’s they show how to set up blender for easier use with UE4 http://www.youtube.com/playlist?list=PLXWXR2pLy_hV6UwhLjirhNnelWpOzGWRI

any probs just give me a shout here and we’ll see where we can help you

edit: the default size in blender is mm i think so basically scale everything up by 100 then use ctrl+a to reset the scale and export

pps to check the sizes in editor create a 3rd person template, import your mesh, then place the hero character in the map and then your mesh, this will give you a good idea to the sort of scale you need to use

Well I did scale it, but that’s not helping. If I export it without the armature, it is fine as a static mesh, but as soon as I attach the armature to it, it breaks.

Okay applying the scale fixed the size issue, but the mesh still comes out rotated:

have you tried turning on the “use TOA’s ref pose” option when importing to UE4? that usually fixes it.

Also make sure that you go to Object-Apply-Location/Rotation/Scale (beside the mode tab) -> this sometimes also fixes such problems :slight_smile:

@Geodav
Hi, just came across your videos about Blender to UE4! Great job!

Thanks
Best Regards