Download

Exportet Shipped Game wont work, Texture Streaming Pool over Budget

Hello :slight_smile:

I recently startet to create a game in UE (V4.26). The Game works in the Editor and on my Computer when i pack it for Windows and open the .exe file.
On other Computers it wont work. When you start a new game it crashes because the computer is “out of video memory”. My Textures are 512 or 1024. Why is texture streaming so big?

Can someone explain to me what “Non streaming mips” means and how I can solve this problem? this part is always over 200%, whether I set the Texture Settings to nomipmaps (looks good, wont work ) or default (compressed textures look horrible, still wont work).
I googled it but didnt found a solution, so I am posting this here hoping someone can help me.

Thank you very much and have a good day!
Franzi

Try the command ‘listtextures’ and take a look in the output log. You can see what’s using all your resources there…

PS Non streaming mips and causing your problem, because they should be streaming :wink:

Your textures need to be power of two dimensions (enable mipmaps) and used in a streaming sub-level (not the persistent level) for them to be streamed.

they are power of 2
never heared of streaming sub-levels, I will look into that. Thank you!

thanks, it sems to be the world type textures.
do you mean with “mips should be streaming” that I should enable them in the texture settings? Because I enabled them first but this caused blurry textures all over the place and the pool over budget size didnt shrink at all

All the default stuff should be on in the textures, mips, streaming etc.

During edit play, the texture pool just keeps building up, but in a shipping build, it gets flushed while you’re playing.

If you have blurry texture during editing, you have to just keep increasing the streaming pool. If you can’t do this ( because you’ve run out of GPU RAM ), it means one of two things:

  1. You have looked at a lot of different textures during your session, and just need to re-start the editor.

  2. You are just load too many / high res textures in your level.

1 Like

Thank you for taking the time to explain this to me! I got it now. Have a nice day :smiley:

1 Like