Exported video not matching the preview animation

I’m setting up 2 animation frames, 1 second apart, only slight movement. It’s framed quite far from the model, clicking the play button previews exactly how I placed the cameras. When I export the video, the camera appears right up against the model, so close that the screen is just a mess of pixels. Any ideas?

Hello Darren,

please excuse our late response. 

Can you please give us more details about your project, such as number of inputs, if georeferenced, size of the model.

Also can you please post some screenshots of the incorrect behavior so that we can better understand it? Thank you.

The model is 955 36MP nadir images from an aircraft at 1500ft. It’s georeferenced but some of the camera location metadata could be wrong, the flight tracks look flipped after RC alignment. Here’s a link to Dropbox with some screenshots, with videos of the 1 second animation in RC, and the weird exported video.

https://www.dropbox.com/sh/0l5m4ipwdxvdi36/AADXJppN4UqbS1BYqiu9_2owa?dl=0

I’ve removed all geo EXIF from the images, started the project from scratch, added GCPs, and made new animations. It’s still rendering a completely black video, because the exported video isn’t matching the animation locations. I’m getting desperate. Any ideas?

Hi Darren,

              The orange lines in two of the images you have sent represent the discrepancy between the calculated camera position and the GPS position of the camera, can you confirm that these lines disappear after stripping the EXIF data from the inputs?

Correct. Here is another Dropbox with screenshots showing the difference between the animation and the render. This is with non geo images, but added GCPs. Sometimes, such as this case, it will render everything completely blank except for the photos in the top left of the 4 screen composite.

https://www.dropbox.com/sh/5cq35lk908cb9lb/AAAQ9wi7oyXNW2lc_huXFN6ca?dl=0

Hi Darren,

              a couple more things, what is the size according to the info panel, and also please can i see , the 1D for a selected keyframe? this should appear when you click on a keyframe.

I’ve updated a screenshot in that dropbox with 1D keyframe info, also selected component info, I’m not sure if that’s what you meant by the info panel. If not, please tell me which panel you are referring to

Hi Darren,

if you click on this

it should tell you the size of the component in the 1D.

Ok thanks. Screenshot:

Hi Darren,

              Thank you for all of this information. We would like to have a look at your project if possible, to try and diagnose the issue. Please contact us at support@capturingreality.com

Hi Darren,

              Just to keep you in the loop, we have your files and are currently looking at the project.

Hi Darren,

            thank you for your time, and thank you for reporting this, it has been filed as a bug, and the developers are currently working on it. I noticed the fly through video export is still working in your scene, and you can select which cams to fly between. But your best option for a workaround is to export the model and animate your cam in a third party 3d application for now.