Exported fbx mesh does not export correct scale from construction script based BP

I’m not sure if this a bug or if I am doing something wrong here but essentially I am creating a level blockout BP that uses a lot of construction script to set the scale of meshes but I need to be able to export the meshes correctly for use in 3ds max, problem is that in the export the mesh used in the BP resets to it’s default scale of (1,1,1)

Here is a screenshot in UE4:


And here are the same objects in 3dsmax, the fbx file resets the scale in the export.

This has been persistent in a few versions of the engine now and I can’t seem to figure out a way to solve it, so reporting it as a possible bug.

Any help on this would be appreciated. :slight_smile:

Hi Jbroderick,

This probably has to do with your workflow, if you are clicking file > export all then this behavior seems expected as your are exporting the scene in its current state without blueprint features included. This means any offsets made in the construction script won’t be included.

What you want is to have all static meshes selected (you can do this quickly using the world outliner provided your scene is well organized). Right click in the viewport and select the option “convert to static mesh”. This will create a static mesh that will preserve the construction script offsets that you can then export from your content browser into Max.

Let me know if that helps,


Hi Ed,

This would even do the same thing with file > export selected. I did just try the other method you have described and it does work but this has the issue of not having the mesh exactly where I want it in regards to the whole scene as then I have to try and replace the new generated static mesh in the exact place in the scene, delete the original BPs and then export. Is there a way to quickly convert the BPs to mesh and then replace them all in place with the singular static mesh version?

Hmm actually I’ve just come across ‘Merge Actors’ command which does what I want so I can export that mesh fine, the only problem with that method though is I can’t find a way to keep the pivot in the merged actor at the centre of the actors I selected, I can only seem to keep the pivot from the first selected object or use the world 0.

My other thought was possibly using an empty actor in the scene as a fake root for the merged actors so the pivot would align to that allowing me to position the pivot manually.

I’d say that would be a valid solution to your situation. Let me know if you run into any other issues.