Export your creation. There is a problem. Project does not contain all inputs!?

Hi there. As the topic says, the problem should be a bit known already but I did not find a solution.

If I want to export my mesh as usually, RC give me the message “The project does not contain alle inputs which were used to create the result”. As some people already said before as I do know: “I never touched anything”. All my input files are on C: in a File Folder on SSD. I cannot understand why this message comes. It took so many manual ours to create this complex project.

The thing is: If there “should” be “really” some input missing, why can I see all of my input files insie of RC? I can click and see every single image, every single laser scan. I can create textured mesh-renderings. So RC MUST have those inputs inside. It makes absolutely no sense to mee. It’s not the first time that that happens. Right now I cannot restart the project again to hope I can export it for another try.

I have read something in older posts about “relinking” images? How does that work?

I have already reset RC and first and only after dozen useless failed trials to export, I have shifted the images in a new folder on the same Hard Drive and restarted RC that it asked me for those image files.

Any other ideas? As I said, this message makes no sense to me if I can create renderings, even 4K Video files from my textured mesh within RC but I have no option to export?

Many thanks in advance

Hi Tuningflex,

what version of RealityCapture do you have? (PPI, ENT)

Did you moved the images to other folder? You can check the used folder in project here:

Please right-click on your RealityCapture project (.rcproj) and view it in an application like notepad c++ to easily navigate through it (it´s an XML file).
Please verify that every image that is in the file corresponds to the actual image and path on the hard drive and any of these images is not corrupted (even a preview of one image can be all green/black/pink)

Then please try to remove cache and make it like a clean install:

  1. removing cache (navigate to your cache location and remove the cache folder) If you are using a system cache it will be in the C:\Users"User"\AppData\Local\Temp      and there search for RealityCapture, RealityCapture1, RealityCapture2. RealityCapture3 folders
  2. Please try to " make it like a clean install" (this will reset your settings to default in the process):
    In order to do that:
  • Shift + Double LeftMouseClick on RealityCapture icon
  • From drop-down select make it like a clean install and press ok
  • Then try again

Have you tried to export the PPI license file by clicking on “input licenses” in the workflow tab of RealityCapture, closing the project, opening it again, and drag and dropping the PPI license file back to the application?

Hi Ondrej,

thanks for your fast anwer. I have tried all of your suggestions a few times but without any success.

I am using a PPI license. Meanwhile with your new beta “tarasque” - but the project was created with an earlier version. And with this earlier version were starting the problems. But with tarasque it’s the same. I hoped it would help to update but it does not.

I have also re-created “fresh” JPEG files under the exact same file names as from the beginning from Lightroom. RC accept them but if I want to export, the samme error appears.

I also cannot export the license file from “input licenses” - it gives me also this error message “there is a problem”.

The thing is that I would like to license the project but I cannot. If I click on “Export” than the first message says as usual: “Creating a digital signature for each input”… this takes about 2 till 5 minutes from 0 to 100 %. After 100 %, the “problem” -message appears every time. Could it be that the reason is here to find? I am really very sure that all my inputs are uncompromisingly complete and unchanged and valid from the beginning to now.



if you recreated new JPEG files, these are consider as new ones, so this could be the reason, why you’ve got this issue. If you are working with PPI, you couldn’t change the inputs anyhow. Then it is consider as a new image, which is not licensed.

Ondrej, I did this only as a test AFTER I was posting here. Because I have nothing left to lose. The problem exists from the very first try to export with all original unchanged images files.
Please believe me: I have never touched anything. Right now I try a bit around because I think it could not become worst than it is.
Meanwhile I am very desperate. Is there any way you can take a look in my project?

Can you please contact us on our support mail? support@capturingreality.com

There we give you next instructions.

So how to fix this problem while not redoing all the project from scratch???

4 similar tickets in support, and no solution in any? 1 year ago, 2 years ago, and still the same issue causes few days of work down the drain, redoing the whole project from scratch??? what a weird software

Make that another user with the same issue…  Not touching the input data or folder and getting this error over and over again.

Hi sanderson70, did you try all previous advices? What kind of data are you processing? Where are your data saved? What was your workflow there?


Thanks for writing.  

The steps I take to re-create this error:-

-  new file

-  input a list of 16 bit .png files

  -  accept create .jpg model images workflow dialogue

    - create images alongside originals

-  align

-  calculate model

-  export high res mesh 


  • I am storing the images on a local disk with a fixed path so nothing can change there.  RC shows correct absolute paths in the interface to each file.

  • My images are not moved or modified in any way.

  • The project is not moved, it is stored alongside the source images

  • My internet connection is very stable > 160 days MTBF

  • There are 86 16 bit .png inputs


I suspect there is something wrong with the code handling the situation with 16 bit source conversion to 8 bit .jpg for modelling as I can repeat this error consistently when using that workflow.  If I do not convert the source files and keep them 16bit I do not get this error.  Sadly, I get far worse results in colour and alignment accuracy so this is not a solution.

Hi, thank you for description. One more thing, what kind of license do you use?

Oh, of course - sorry for neglecting to add that.  I am using PPI licencing.



I was trying achieve this, but wasn’t able to do so.

When you are transforming 16bit images to 8bit you are basically creating new ones. Is it possible, that you imported the same images into another project during computation?

Did you already licensed your inputs? Which one (16 or 8 bit)?

When you move the images into another folder, does it ask you to select correct path to the images?

Is it possible to share the project and the used data?