Download

Export issues from Maya 2018

Hi,
I am trying to export from Maya 2018 to Unreal 4.7.6, and I’m not having any luck. My workflow is as follows:

Launch Unreal, create new project, blank, with Basic Code
Launch Maya 2018, create a polygon cube
Export cube from Maya as fbx. I have tried export all, export selected, and the Export To Unreal option, with the same result:

In Unreal Content Browser, import cube.fbx. I tried leaving the default import settings on, or unchecking Import Materials and Import Textures (since I have no texture)
Result is a Message box saying:

Failed to import ‘(…) Unreal Projects/MyProject/Content/testcube.fbx’. Failed to create asset ‘/Game/cube’

Unreal also crashed a couple of times.

Maya has both the gamefbxexporter and fbxmaya plugins loaded. fbxmaya version is 2018.1.1. Unreal docs state that Unreal uses FBX 2016, but there doesn’t seem to be a way to install that in Maya 2018? At least my Google-fu is failing me on that.

I did find a couple of people who seem to be able to export to Unreal from Maya 2018, so there has to be a way to do this. Does anyone have any advice on what I am doing wrong?

In the FBX exporter you can go down in the options and change the version of FBX you want to use.

As darthviper107 alluded to, if you’re using Maya 2018 with UE4 4.7.6 you’re going to need to lower the version of FBX. 2014/2015 should resolve the issue for you.

ExportFBX.jpg