Export FBX with morph targets from UE4

I recently purchased a character asset from the marketplace that makes use of a number of morph targets for customization.

If I want to be able to make my own clothing for that character I need to export the existing morphs from UE4 in order to deform any new clothing assets to work with them.

Is it possible to export morph targets in an fbx from within UE4?

No, it’s not possible to do this.


1 Like

Hi, it’s still impossible to do that?

Hi, it’s still impossible to do that? ue4.21

I’m working in Blender, and it still doesn’t seem to be possible to export morph targets and then import them as shape keys in Blender.

However, I think I have a cumbersome way to get around it.

In Unreal, you can open your character mesh, edit one morph target to its maximum value, and then ‘make static mesh’. You can then copy out all of the morphs as static meshes. Also export a static mesh with no morphs applied.

Then in Blender, import all of these static meshes. Use the ‘join as shapes’ function to combine these morphs back into the base mesh. Add your own morphs as you see fit.

You then need to export a skeletal mesh of your character from unreal into the Blender scene. Copy the vertex weights from the skeletal mesh to your static mesh. Use the weight painter to double check that the weights have been transferred. Delete the crappy morphless mesh from the skeleton. Parent the morphed mesh to the skeleton with empty groups. The mesh with all the morph targets (shape keys) applied should now be rigged to your skeleton. With the proper settings, this should export back into Unreal.

You should now have a working Blender file from which to morph to your heart’s content.

Fixed in 4.23.
See [Unreal Engine Issues and Bug Tracker (UE-30020)][1]

I am using 4.23 and it is still not working for me. It is not visible in Blender. But, when I do import exported file into other UE4 project the morph keys are visible. Even with that “Export Morph Targets” option turned on.

Using 4.27.2 and shape key still not visible in blender. But it’s working in other engine.

This is more a Blender problem than an Ureal problem, it seems. I ran into this same issue, but then I realized that when I import the exported FBX back into Unreal, it does in fact still have the morph targets. They absolutely are being saved to the FBX; Blender just doesn’t “see” them.

How I fix this problem: First, I make sure to export the FBX as ‘FBX 2013.’ Then, I use FBX Converter (free at Autodesk’s website; I’m not sure if I’m allowed to post links here) to convert the FBX. After this, when I import the “fixed” converted FBX into Blender, it miraculously now has all the morph targets.

NOTE: Be sure to rename the skeleton to ‘Armature’ before you export it from Blender.