Export 3D view to Unreal Datasmith broken

Just getting a generic error message when clicking the unreal datasmith button in Revit.

“3D view rendering is not supported in the running Revit”

The error message is not even in fluent English? The only option is “Ok” and no matter what, Revit/Unreal throws up this error message in 2019.

Has anyone else seen this and been able to resolve?

Hey KM3d300

What datasmith plugin version are you using ?

Try updating to the latest version available at Datasmith Exporter Plugins - Unreal Engine (the 4.25 plugin release will work fine with both Unreal 4.24 and 4.25).


Hi, thanks for the msg.

I’m using 4.25 version and Revit 2019 (latest service pack/patches for Revit) and Windows 10x64 Pro.


from what we can guess, its possibly because you don’t have any of the autodesk materials installed. Our exporter relies on the render api of revit and when rendering is disabled, it won’t work. Can you render viewports in the “realistic” mode in revit? If render features of revit are disabled, that might explain it.

Thanks, I’ll give it a go.

The other thing is I’m operating revit via mstsc (remote session via microsoft’s rdp ) so was thinking that might be it.
I’ll check with the autodesk materials though,

So it looks as if the materials are installed.

I tried on another Revit Project and the same error message occurs.

2020-05-27 14_32_35-Window.jpg

Ok, so just reinstalled Revit.

Probably should’ve done that first off but that’s the solution if anyone looks this thread up in future. It’s a real pain to install Revit but it fixed the issue whatever it was.