Download

Exponential Height Fog looks bad through a scene capture

The fog seen in the editor or through the main camera looks quite nice, it creates an “infinite ocean” illusion with ease.
Not so when you look through a scene capture though, the fog becomes more like a thin shell that washes out the objects behind it a little.
Any ideas to fix this?

main camera

capture camera

Anyone got any ideas on how to fix or work around this? I’ve used material effects to make the captured background more faded and so on, but it would still help me a lot to get fog fixed.
Another way would be to somehow implement fog through material nodes, since you can run any material on your render capture…

Check the end of the page here in “known limitations”
https://api.unrealengine.com/udk/Three/RenderToTexture.html

I remember having similar problem and foud that some effects dont work with scene captures.Just some.But fog shoud work fine.Did you select the fog option in the scene capture properties,shadows and stuff?Also make sure your scene capture texture is using good resolution like 1024x1024 or 2048x2048.
Also, if the water is transparent plane, probably check to see if the transparncy sorting is ok.

Thanks for getting involved mate, but I think I already tried those things you said.
Check this video, you can see I have a good scene capture res and fog is enabled

](flying and fog bugs - YouTube)

I also tried reducing the scale of my environment by a factor of 10, landscape and meshes, didn’t do anything, same fog peeling bugs.
Unless I’ve missed something the only option might be to fake fog with material nodes but I’m not good enough for that tbh.

So the problem is that the fog is clipping(hard line edge thing)? Did you tried to give the fog a minimal distance of 0?

Cool game by the way.Used to play Ikaruga on the gamecube :cool:

Oh ****, you’re right, Fog Start Distance > 0 causes the fog peeling bugs…BUT that’s the problem actually
Because of the broken Scene Capture + Fog Start Distance interaction, I can’t control the fog properly, that’s what is used to control where the fog starts to fade towards full opacity.
So I can only have either almost the exact same fog density across the whole screen with distance 0 (looks like a material overlay, not real fog), or no fog.

Btw thanks, Ikaruga is one of my top favorites, I’ll post some more videos soon I think, hopefully the 3d backgrounds will be just as cool.

Or you can use the your basic fog with 0 distance but make it very light, and than place in the level fog volumes which you can scale to size and control their density.

Yeah I guess I could try for that, it’s still nowhere near real fog that fades away as you get close but much better than nothing. Thanks.

I would be surprised if there isn’t a material node solution for this though