Download

Excluding landscape spline wth static mesh from foliage generation

Currently you can specify a landscape layer to prevent a foliage spawner from spawning on it. However, I have a spline that has a static mesh (for a road) on it. As long as the mesh is on the spline, the foliage tool will ignore the layer filter and spawn on top.

Is there a way in 4.24 (or higher) to exclude such a spline ? The paint/fill tool does not help because the landscape splines do not seem to be visible in the editor placement mode (only in landscape “manage” mode)

No, but if you apply the correct layer to the spline and apply that to the landscape you would get the same result.
just remember that its not easy to undo this. Paint on the landscape is permanent if you save and exit or run out of undo functions you would have to reverse it.

So: I am applying one of my landscape layers to the spline. It seems correctly applied because without the road spline I can see the difference in appearance. I can exclude the layer in the foliage spawner and it will not generate foliage on the spline.

However, when I add a static mesh to this same spline, the foliage will spawn on top of this static mesh.

Could you then please clarify what you mean by “apply the correct layer to the spline and apply that to the landscape” ? I think I am doing everything correctly, it just does not work.

thanks!

The foliage shouldn’t be spawning on top of meshes. What type of spawner are you using?
is the layer still applied below the mesh?

I am using the Procedural Foliage Spawner with a Foliage Type that has a simple foliage static mesh in it.

The layer is still applied to the spline as far as I can tell.

bumpitybump

bumpitybump

This may be long overdue but under “Procedural Foliage” settings within the PFS, check “Allow Foliage” and uncheck “Allow Static Mesh”. It should now remove any foliage that is colliding on your splines and/or static meshes you link to it. I hope this helps!