Exclude object from a specific light.


I can’t find an option of excluding a specific mesh from a specific light.
There is an option like that in 3ds max. There I can choose that a given light will simply ignore a chosen object.

So is there such an Exclude option in Unreal? If not, I look forward to it.

I stumbled upon this issue when I wanted to create a curtain and window glass in an interior scene. When I use exterior lighting coming through the window, I firstly don’t want it blocked by the window glass, secondly I don’t want the curtains to be dark on the back side. (I already switched off shadow casting in the curtain mesh but still it seems dark on the interior side). Simply changing the parameters of curtain mesh resets the lightmap of the curtains and it is white again (the way I want it). So for now I will simply ignore the lightmap calculation, play with the curtain settings so that Unreal Engine shows that the lighmap needs to be reset. Sometimes I want to exclude the objects from lightmap so that it looks exactly like it looks by default after importing the FBX mesh to Unreal. Is there a way to make it permanent?

Thanks in advance for consideration.

Hi Yarek,

Unfortunately, this is not possible with Deferred Rendering.

Thank you!


Hi Tim,

This is still not possible ? Can an object (movable) be set to not to receive any lights from a specific light source (skylight) ?

At the time it was, we have lighting channels now, but only for movable lights.

Skylight does not use lighting channels, though. Only Directional, Point, and Spot lights.