Excessive Battery Drain Vanilla Macbook Pro Retina UE4 Install

Hi All.

I just started working with UE4. I have a new Macbook Pro Retina 13-inch Mid 2014 CPU 2.6Ghz Intel Core i5, 8GB 1600Mhz DDR3, Intel Iris 1536 mb Graphics, OS X 10.10.2 with 256GB PCIe flash.

Installed UE4 4.7.3 for first time. I created a default blank blueprint project with Starter Content disabled. I also installed latest XCode. I updated OS X with latest updates. There is nothing else installed on this machine. I literally took it out of box and put UE4 on it. project consists of a cube, a floor, and a directional light, with a player start object.

Upon switching windows to UE4Editor CPU fan begins to ramp up speed and my battery drains from a full charge down to 20% in just 2.5hrs. Engine Scalability Settings are all set to Medium by Auto Detect. Effects is only exception which is set to Low. Real time is disabled in viewport. There is nothing in my Scene that would cause heavy rendering. I am simply following getting started tutorials for editor. I haven’t been using the ‘Play’ feature in editor either. Note if I switch to another application in background fan speed returns to normal. Use Less CPU when in Background is checked in UE4. cpu fan speed ramp up isn’t always dramatic but impact to battery life is apparent.

Note I use a 13-inch Mid 2011 Macbook Air to run Unity 4 Pro which lasts me 4 - 5 hrs including playing and building my projects for Desktop and Mobile games. I recently upgraded to a Macbook Pro Retina (less than a week old) in hopes to run UE4 while traveling but these performance issues are making it very difficult to use.

Please advise further.

All best


No this does not help. You told me to raise a separate request in hopes to tackle this issue anew with someone new please. No offense just need a fresh pair of eyes on case.

Activity Monitor reports CPU utilization at 120% with editor not doing a thing. There is one unskinned cube in entire scene. If I run empty project with a Player in it (pressing Play button) CPU utilization jumps to 140%!

This is completely unacceptable. I don’t even have complex assets loaded yet. And I cannot use your starter content for testing because of other bug. There is no reason why a brand new MacBook Pro Retina should be this stressed in an empty blueprint project.

At this point I’ll need to return MacBook if apple will let me and scrap using UE4.

Hi Tom,

This is normal behavior for Macs. Things should get better in 4.8, but Slate is quite demanding. You can try limiting your max fps to something like 20 or even 15 to reduce CPU/GPU usage and increase battery life by using t.maxfps console command. Hope that helps some!

You do need a pretty beefy machine to run UE4, or any game engine for that matter. It’s par for course.

Honestly, in spite of marketing to contrary, I’ve never found Macbooks to be optimal tool for this type of work, you may be much more happy with a tower based workstation in long run. other solution of course, is to plug your laptop in.

You need a Mac to develop for mac. I need to travel on top of that. I get roughly 4 to 5 hours on Unity Pro on a battery that’s 4 years old which includes building my games on XCode for iPhone. I only get 2hrs on UE4 on new machine and I am not doing any work yet. editor window is simply maximized. I think there is a problem with software. Note this post is not intended to compare products like Windows vs Mac or Unity vs UE4 I need both respectully.

PC Mag rated newer model at 13.4 hrs (what I bought)

I expect at least 4 hours for real world use.

One thing to try - in dropdown in upper right hand corner of your 3d view, is ‘realtime’ checked? I find that turning that off helps a lot since most of time you don’t need that viewport updating continuously.

Thanks for trying to help but if you read my initial post you’ll see I’ve done all that. Here is a screen shot of my CPU at 170%. All I did was start UE4 with it’s default empty scene. I didn’t open my own level. My Engine Scalability Settings are now set to Low with 25% resolution.

120% you’re seeing is per logical core, so it’s really 30% of CPU, assuming your i5 is dual core. Limiting max fps would cut your CPU load by well over half, which should bring it down to about 10 - 12% on your MacBook Pro.

If you’re getting 2.5 hours battery life on MacBook Pro with UE4, that’s actually pretty good. We’re displaying more advanced stuff at a much higher display mode on more power-hungry hardware. While our templates do not have a lot of geometry, they’re running full renderer, including very expensive post-process shaders.

Mac shouldn’t be more impacted than PC by Slate. Generally, laptops don’t have power necessary to run UE4 as well as a desktop machine; Slate is just not really a laptop-friendly design. This would likely be same if you were using a PC laptop with similar specs. We’re testing in next couple of days to see if there’s a difference between CPU usage on Windows vs OSX on same MacBook Pro, but we expect difference will be minimal. Windows itself drains battery much faster than OSX, so it might not be a fair comparison.

I’ve been discussing this all day with several of developers who work with Mac, and they’re all saying same thing.

I was hitting 2.5hrs with an empty scene open this is a bit unrealistic for a real world example. If I was developing a mobile game my battery would fall far short of this estimate. My CPU utilization has risen to 170% in some cases.

I agree that OS X is averaging better battery life by OS comparisons. Though I imagine with Direct X you might see better numbers for windows which I’m sure UE4 is optimized.

So far best band-aide solution that I could come up with is to throttle CPU for Editor PID with a program. I admit this is a bit ugly but I was able to extend battery usage a bit to handle simple prototyping. By limiting CPU to 50% I’m getting 2hrs at 50% battery. I don’t hear CPU fan either. intel power gadget shows a drop in temperature at 76C.

CPU LIMIT - Formerly known as cputhrottle on sourceforge moved: GitHub - opsengine/cpulimit: CPU usage limiter for Linux

Ideally in next UE4 update I would love to see a low power mode made to support portables. Or something for Macbook Pro users (it’s not like they change all that much). And or something that allows us to adjust Intel SpeedStep within UE4. That would be helpful to mobile developers.

I’ve dug around Unreal forums, it seems Mac performance issue comes up a lot. There seems to be an issue running launcher / editor at same time. general answer is ‘we’re working on it’…