Example game not loading

thought i’d try the first example game again but could get it to load properly, got some errors then it tried to compile the shaders, switched it off after 10 mins attached the logs in case they might help
link text

link text

Were you ever able to get it running before? Are you using the latest Rocket Beta (Beta 2 I believe)?

worked fine with the beta 1, doesn’t work for me with beta 2,
as the log showes
tried generating the script files and re-building but that brought up errors in VS2012 express
Error 1 error : In ShooterPawn: Blueprint accessible functions must have a category specified E:\RocketGames\ExampleGame_Beta\ExampleGame\Source\ExampleGame\Classes\Pawns\ShooterPawn.h 197 1 ExampleGame (ExampleGame\ExampleGame)
Error 2 error : In ShooterAIBase: Blueprint accessible functions must have a category specified E:\RocketGames\ExampleGame_Beta\ExampleGame\Source\ExampleGame\Classes\AI\ShooterAIBase.h 109 1 ExampleGame (ExampleGame\ExampleGame)
Error 3 error : In ShooterAIState: Blueprint accessible functions must have a category specified E:\RocketGames\ExampleGame_Beta\ExampleGame\Source\ExampleGame\Classes\AI\ShooterAIState.h 148 1 ExampleGame (ExampleGame\ExampleGame)
Error 4 error : Failed to generate code for ExampleGame E:\RocketGames\ExampleGame_Beta\ExampleGame\Intermediate\ProjectFiles\EXEC ExampleGame (ExampleGame\ExampleGame)
Error 5 error : UnrealHeaderTool failed for target ‘ExampleGame’ (platform: Win64, module info: ). E:\RocketGames\ExampleGame_Beta\ExampleGame\Intermediate\ProjectFiles\EXEC ExampleGame (ExampleGame\ExampleGame)
Error 6 error MSB3073: The command ““D:\Rocket\Engine\Binaries\DotNET\RocketUnrealBuildTool.exe” ExampleGame Win64 Debug -rocket=“E:\RocketGames\ExampleGame_Beta\ExampleGame\ExampleGame.uproject”” exited with code 1. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110\Microsoft.MakeFile.Targets 38 5 ExampleGame (ExampleGame\ExampleGame)

the errors all seem to point to this function UFUNCTION(BlueprintCallable)

but then i can’t code so i might be missing something else

Functions exposed to blueprints now require additional tag in UFUNCTION line. Please find all occurrences of BlueprintCallable and BlueprintPure in ExampleGame/Source/Classes/ and add: **Category=“MyCategory” **

e.g. UFUNCTION(BlueprintCallable, Category=“MyCategory”)

It will solve that error and code should compile.

just tried again but no joy
most of the errors point to OVERRIDE; now
attached the VS build errors

if it take to much time the just leave itlink text

Hi George,

Are you saying that Lukasz’s solution was unsuccessful?

sorry for the late reply, Lukasz’s did clear those errors but i now have more !!!
as mentioned above i don’t want you guys to waste time on stuff thats not going to be released again. maybe later one of the rocketeers could have a look. i don’t need it badly so no real lost atm

Uh… that’s a huge (and incomplete: only first 100) list of errors. I strongly suggest starting project again, based on supported sample (ShooterGame), to avoid problems with native code in future QA builds.

Some of those errors are caused by function/variable renames, variables moved to different classes. Other require more code changes (collision channels and responses, input), by programmer using existing sample game as a template.

Can you use previous QA build to run game again, so you can access and export content?

thanks Lukasz for the info, i think i’d best leave it as it is, this goes way to deep for me, i still have the first beta stored on my harddrive so if i need it then i’ll re-install it and have a go.
sorry to have wasted your time on this.

Hey George,

We got the same issue on our end, I submitted a report. TTP# 299204

Best Regards,