Download

ex-Unity user trouble importing texture with model.

Hey guys I just switched over from Unity and so far I am not regretting it because of the Blueprint system! I do however have one problem importhing fbx models exported from google Sketchup. In unity, I simple dragged the object and materials into the project tab, and the object would be there materials attached and everything. In UE4, I’ve tried so many things but the texture just won’t go on the object. Any help please? I’ve tried unchecking different options like the “overry fullname” and the “combine meshes” and other various combinations, but no success. Can anyone help with this? btw I’m using fbx files. Thanks.

Just follow those steps (easiest way ;)):

  1. import your object(so the fbx file)
  2. import the textures (export them from your 3d program)
  3. right click onto the texture - create new material (now you can edit some stuff → e.g various effects,…)
  4. open the object - and in the static mesh editor you will find some material slots - now just select your material in the content browser and then add them to those slots

Thanks, I will try this and get back to you!

I have never been able to import the model with texture without the engine crash so i just take the long way and upload the texture separate. what i do is enable the import material option so i don’t have to make and name my materials i just edit it and add my stuff.

wizzkidsan, can you give some more details on what you do, I’'m not exactly understanding how you are doing that. Sorry I am very new to the system so I am still on the steep part of the normal curve

ok in your import options hit the drop down for “Advance” then go to “Materials section” and ensure that “Import Materials” is checked then just import, you should get you model file plus a material in same folder double click material and then add your textures and do your setup.

Thanks fighter5347. I think it seemed to work, though I was guessing which materials to put in each slot. For some reason, now my table model just falls through the floor. I tried to match the properties to that of the chair that comes with the standard props, and make sure all the physics options match. but it still falls through. can you help with this? if u need me to provide screenshots or send you the project that would be fine also. thanks so much!!

Go into the static mesh editor and add one of the collision that you can find in the collision tab

http://www.youtube.com/watch?v=TTsAYpqHU-c (4:00)

or just upload the file somewhere and then I will take a look at it :wink:

Thanks guys I actually found a really easy way to do it! I’ll post a separate thread for newbies so everyone can benefit!!!

In general I found that importing materials using FBX is rather picky at times and some times works, some times it does not, and some times UE4 locks up.

I suspect this is caused by the fact that all 3d applications manage materials differently and would be near imposable to get a 1-1 match moving content out of one app and into another and it’s more luck than anything else if it does work.

More of an annoyance but overall I think it’s best practice to rebuild the material in UE4 anyways as UE4 tends to pull in all of the textures from the FBX including the ones you don’t want.

did you import the materials on the file? if so maybe the engine gave an error with the import. When i import my material on the file i get a blank pre-name material on my models so this way i don’t have to guess where mhy materials go and plus instead of creating a new material i can just edit the blank materials that was imported.