Everything too slow when open blueprint editor

The problem was a simple memory leak on FNullSourceCodeAccessor::CanAccessSourceCode(). I just edited it to cache the result in a static bool and it worked just fine. Even better than on Windows. Thank you RCL, the one who showed me the solution =)

Thank you for the reporting this. After profiling, we identified the problem and fixed it (in 4.17): https://github.com/EpicGames/UnrealEngine/commit/dbd864dc2de889a87a5b5a1d4d0c7cb58249c372 You can merge the proper fix to 4.16 or simply (as a hack) change NullSourceCodeAccessor, function FNullSourceCodeAccessor::CanAccessSourceCode() to cache the returned value in a static boolean.

You are welcome. Just a small correction: this was not a memory leak. That function was called too often, and since it is rather expensive on Linux, this has been slowing things down.

I get something around 60-100 FPS when I’m running editor / playing in demo mode. But as soon as I open blueprint editor the whole thing slows down to 10 FPS, just doesn’t make sense. I’m running on Linux, my specs meets the recommended hardware but just doesn’t work well when I open blueprint editor. Not to mention that it work just fine when I was on Windows. Anybody knows why? I’m using Debian Stretch with latest NVIDIA drivers, I have a GTX 750 ti 2 GB and the GPU usage keeps at 800 MB but still the blueprint editor just make everything run slow. How can I fix it? I don’t wanna go back to Windows